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Code C-QGIS-A+B

Title QGIS Essentials and Advanced

Description Key aspects of using QGIS, Advanced QGIS topics

Required Software QGIS 3.4

Target Audience GIS Professionals

Pre-requisites Basic GIS skills

Duration 3 days

Version 2.0

Updated 07 May 2019 

Updated by Antony Scott

Status Complete

Introduction

This course is designed to introduce GIS professionals to QGIS, including functionality such as:

Loading and styling file-based and database data

Editing data

Filtering and querying

Connecting to web services

Print outputs

It also covers some advanced topics, including:

Raster processing

Geo-referencing

Atlas generation

Animations

Prerequisites

Delegates should ideally have some experience in a desktop GIS package, for example MapInfo or ArcGIS.

Course Modules: Essentials

QGIS-01 v3.0: Getting Started with QGIS

QGIS-02 v3.0: Vector Data in QGIS

QGIS-03 v3.0: Styling in QGIS

https://astuntech.atlassian.net/wiki/people/557058:c1a4281b-182c-4434-8cc5-337ef0a7929e?ref=confluence
https://astuntech.atlassian.net/wiki/spaces/AT/pages/219283536/QGIS-01+v3.0%3A+Getting+Started+with+QGIS
https://astuntech.atlassian.net/wiki/spaces/AT/pages/233275549/QGIS-02+v3.0%3A+Vector+Data+in+QGIS
https://astuntech.atlassian.net/wiki/spaces/AT/pages/233505349/QGIS-03+v3.0%3A+Styling+in+QGIS
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QGIS-04 v3.0: Select and Filter in QGIS

QGIS-05 v3.0: Raster Data in QGIS

QGIS-06 v3.0: QGIS Data Creation and Editing

QGIS-07 v3.0: QGIS Geo Processing

QGIS-08 v3.0: PostGIS Data in QGIS

QGIS-09 v3.0: QGIS Print Layouts

QGIS-EX01 v3.0: QGIS Essentials - Exercises

QGIS-P01 v3.0: QGIS Plugins

Course Modules: Advanced

QGIS-A01: QGIS Atlas v 3.2

QGIS-A04: QGIS Georeferencing v3.2

QGIS-A05: QGIS Raster Analysis v 3.2

QGIS-A06: QGIS Graphical Modeler v3.2

QGIS-A07: QGIS Time Manager v3.2

QGIS-A08: QGIS Point Cluster Styling

QGIS-P01 v3.0: QGIS Plugins

https://astuntech.atlassian.net/wiki/spaces/AT/pages/235798705/QGIS-04+v3.0%3A+Select+and+Filter+in+QGIS
https://astuntech.atlassian.net/wiki/spaces/AT/pages/300220659/QGIS-05+v3.0%3A+Raster+Data+in+QGIS
https://astuntech.atlassian.net/wiki/spaces/AT/pages/304185473/QGIS-06+v3.0%3A+QGIS+Data+Creation+and+Editing
https://astuntech.atlassian.net/wiki/spaces/AT/pages/305463324/QGIS-07+v3.0%3A+QGIS+Geo+Processing
https://astuntech.atlassian.net/wiki/spaces/AT/pages/306380906/QGIS-08+v3.0%3A+PostGIS+Data+in+QGIS
https://astuntech.atlassian.net/wiki/spaces/AT/pages/305430573/QGIS-09+v3.0%3A+QGIS+Print+Layouts
https://astuntech.atlassian.net/wiki/spaces/AT/pages/306348207/QGIS-EX01+v3.0%3A+QGIS+Essentials+-+Exercises
https://astuntech.atlassian.net/wiki/spaces/AT/pages/306151633/QGIS-P01+v3.0%3A+QGIS+Plugins
https://astuntech.atlassian.net/wiki/spaces/AT/pages/377389293/QGIS-A01%3A+QGIS+Atlas+v+3.2
https://astuntech.atlassian.net/wiki/spaces/AT/pages/377094335/QGIS-A04%3A+QGIS+Georeferencing+v3.2
https://astuntech.atlassian.net/wiki/spaces/AT/pages/377323660/QGIS-A05%3A+QGIS+Raster+Analysis+v+3.2
https://astuntech.atlassian.net/wiki/spaces/AT/pages/377618433/QGIS-A06%3A+QGIS+Graphical+Modeler+v3.2
https://astuntech.atlassian.net/wiki/spaces/AT/pages/377913496/QGIS-A07%3A+QGIS+Time+Manager+v3.2
https://astuntech.atlassian.net/wiki/spaces/AT/pages/589725697/QGIS-A08%3A+QGIS+Point+Cluster+Styling
https://astuntech.atlassian.net/wiki/spaces/AT/pages/306151633/QGIS-P01+v3.0%3A+QGIS+Plugins
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1. Getting Started with QGIS

 

1. Getting Started with QGIS
1.1. Introduction

1.2. Menus and Features
Tools and Menus

Layers Panel

Information Bar

1.3. Projects
Save a Project

Creating a New Project

Opening Projects

The QGS Project File

Project Properties

1.4. Map Navigation

1.5. Coordinate Reference
Systems (CRS)

1.6. QGIS Browser
View metadata

Preview the map data

View and re-order attributes

QGIS Browser Panel

1.7. Plugins
Manage and Install Plugins

Recommended Plugins

An Astun Technology QGIS Training Module

Code QGIS-1

Title Getting Started with QGIS

Description Introduction to QGIS history, key
functionality, and UI.

Required
Software

QGIS v 2.14 or later

Target
Audience

QGIS Desktop users

Pre-requisites  

Duration 1 hour

Version 2.0

Updated 08 Mar 2016 

Updated by Antony Scott

Status Complete

1.1. Introduction

QGIS is a mature and fully functional open source desktop Geographic Information System (GIS) package,
licensed under the GNU Public License. QGIS is an official project of the Open Source Geospatial
Foundation (OSGeo). It runs on Linux, Unix, Mac OSX, Windows, and Android, and supports numerous
vector, raster, and database formats and functionalities.

QGIS provides a continuously growing number of capabilities provided by core functions and plugins. You
can use it to visualise, manage, edit, analyse data, and compose printable maps. QGIS is a community-driv
en GIS project - the web site, the source code, the bug tracker and the mailing lists are hosted and partly
maintained by OSGeo. The work of QGIS project management is spread across an international team of
developers and GIS users who each have a specific area of responsibility.

The main QGIS website is at http://www.qgis.org/.

1.2. Menus and Features

QGIS has a configurable interface that can be manipulated and customised according to your preferences -

https://astuntech.atlassian.net/wiki/people/557058:c1a4281b-182c-4434-8cc5-337ef0a7929e?ref=confluence
http://www.qgis.org/
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for example as in the screenshot below. Toolbars and panels can be docked anywhere on the screen or
can be floating. For the purposes of this course, it would be helpful if you arranged the QGIS panels to
something similar to the image below.

Toolbars and panels can be added and removed by right-clicking in the Toolbar are, or by using the  mView
enu .

Tools and Menus

The table below describes the standard menus.
 

Menu Purpose Example tools

Project Working with projects and printing Save as…

Project properties

Print composer

Edit Data editing tools Add feature

Split features

Rotate point
symbols

View Map navigation and managing toolbars/panels Zoom

Grid

Toolbars

Layer Adding and creating new layers as well as viewing layer
properties and controls

New shapefile layer

Attributes

Query
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Settings Various configuration settings Style Manager

Customizations

Snapping options

Plugins The functionality of QGIS can be extended by bringing in plugins
using this menu

Manage and Install
plugins

Vector Tools for working with vector data  

Raster Tools for working with raster data  

Database Tools for interfacing with databases including loading data. DB Manager

Processing Access processing tasks and model builder  

Most of the tools available in the menu are also available in the toolbars.  New menu items (for example We
) are sometimes added by plugins.b

Layers Panel

The  shows a list of map layers that are currently available to display on the map. This mightLayers Panel
include web services, base maps, raster layers, vector datasets and tables.

Note that:

Layer order is controlled by default from the Layers Panel; however it can alternatively be controlled
by the .  Load this panel and use the  checkbox toLayer Order Panel Control rendering order
toggle between the configurations.

Whichever method of layer ordering is used, the layers at the top of the list will appear uppermost on
the map, potentially hiding layers lower in the list.

You can drag and drop layers to move them up and down the list.

You can create a group to hold a number of layers by right-click in the layer list, or using the Add
Group button at the top of the Layers Panel to create a group, then drag layers into the group. 

Click and hold on the group title (or ) on a group title to edit its name.Right-click > Rename
The layer list will show legend information, indicating the symbology used in the map.

Right-click on a layer for a menu of options for an individual layer
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Information Bar

The information bar below the map window provides information about the current map. It is often useful for
changing scale, and checking the current Coordinate Reference System. You can also use it to stop
rendering the map following a zoom or pan if you have a large number of layers on the map.

The button to the right of the Coordinate box can be toggled to show the current map extents.

1.3. Projects

On opening QGIS, a new project will always be created (though not saved), and QGIS will also show a list
of recently-opened projects in the map window. Note that only one project can be opened at any one time
in one QGIS instance, although you can open a second instance of QGIS to open a second project. When
you save a project, the current state of the GIS map window and layers panel will be saved, including
styling, map layout and other settings.

Save a Project

To save a project, go to  Project > Save,  press , or use the  icon in the toolbar. The currentCTRL-S Save
project is saved as a .qgs file.

Creating a New Project

To create a new project, go to Project > New, press , or use the  icon in the toolbar.  If theCTRL-N New
current project has not been saved, a prompt message will appear asking you to save it first.

Opening Projects
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To open an existing project, go to Project > Open, press , or use the  icon in the toolbar,CTRL-O Open
then navigate to the file location of the .qgs file. Alternatively, to find a recent project, go to Project > Open

 to see a Recent list.

If you are running QGIS from a standard installation, you can also navigate to the project file in a file
explorer, and double click on it.

The QGS Project File

The .qgs file holds all the configuration information about the project including:

Layers and layer order

Styles and labelling

Map windows setup

Queries

Joins

Project properties

Print Composers

The project file is stored as XML, so it is possible to open it a text or XML editor. However it is not
recommended that you make changes here unless you are familiar with the file structure - but if you do,
make a backup copy before you start.

Note that source data is not saved in the project file - it remains in its source files and databases, with the
.qgs file simply holding references.

Project Properties

The  dialogue is in the  menu. Here there are a series of controls and settingsProject Properties Project
which apply to the current project only.

Some of the main settings are listed below.

General
Project title: this will be displayed in the title bar of the QGIS window

Selection color: the colour of items when they are selected

Background color: the colour used for the background of the map

Save path: paths to data sources can be either relative or absolute

Measurement units: for distance and area

Project scales: defines the pre-set scales in the information bar

CRS
Sets the native Coordinate Reference System for a project, with the ability to allow
transformations to be carried out on the fly where multiple CRSs are in use.

Default Styles
These can be set to be applied to new layers

1.4. Map Navigation

Map navigation is generally carried out from the  tool bar. The diagram below showsMap Navigation
purpose of the main tools.
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1.  

2.  

3.  

4.  

The mouse wheel is usually the easiest way of navigating the map; zoom in and out by moving the wheel,
and pan by holding the wheel down and dragging.

1.5. Coordinate Reference Systems (CRS)

QGIS can use and translate between all major CRSs, following the EPSG numberings. For example:

EPSG 4326: WGS 84 (Long / Lat)

EPSG 3857: WGS 84 Pseudo Mercator (used by Google Maps)

EPSG 27700: OSGB 1936 British National Grid

The CRS used can be set at a number of different points in the system:

Default CRS for new projects

Default CRS for new layers, and for loading layers with no CRS

Defined CRS for a project

Defined CRS for a layer

For 1 and 2 above, the default CRS for both projects and new layers can be set in Settings > Options >
CRS:
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For example, you might want to set this to ESPG:27700 British National Grid when first installing QGIS.

For an individual project, the CRS can be defined under .Project > Project Properties

To change the CRS for a project you will first need to check  if this isEnable 'on the fly' transformations
not already set - this enables layers with different CRSs to be correctly displayed together. The layers
themselves remain in their native CRS.
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1.  

2.  

3.  

1.  

2.  

Select the Coordinate Reference Systems (CRS) tab

Filter and select the required CRS.

Press OK

Defining a CRS for an individual layer is done in the layer properties, if it is incorrect.

Select the relevant layer and  Right-click > Properties
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2.  

3.  

4.  

Select the  tabGeneral

Under Coordinate reference system, select using the dropdown list or the  button to theSelect CRS
right

Filter and select the correct CRS

1.6. QGIS Browser

The QGIS Browser is a standalone application which can be used to navigate spatial data in files,
databases and web services, and preview the content, including both geometry and attrubutes. For ESRI
users it could be considered an equivalent to ArcCatalog.

The Browser can be used in two modes:

launch it from the start menu or a shortcut if you have QGIS installed on your machine
Note that if you are running QGIS from the Portable GIS memory stick, you will need to launch the
browser from the shortcut  on the root of the stick

bring a more limited version (without preview) into QGIS as a panel, using View > Panels > Browser

Below are some examples of the functions in the full Browser.

View metadata

Preview the map data
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View and re-order attributes

You can also create shapefiles in the browser, and add web services layers.

You can drag files from the Browser to the main QGIS programme, but beyond that there is limited
interaction between the two applications.

QGIS Browser Panel

The  in the main desktop programme is a useful way of interacting with data and bringing itBrowser Panel
into the map. A dataset in a database file can be dragged with the mouse from the  to theBrowser Panel
map. The  doesn’t provide the preview capabilities found in the standalone version. Browser Panel

1.7. Plugins

Additional QGIS functionality is contained in plugins - tools that have been developed for QGIS to extend its
scope or address specialist needs. There are two main types of plugins:

s: Core plugin installed by default

Optional plugins: accessible in the QGIS Official Plugin Repository
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To install, upgrade, uninstall and control plugins, use Plugins > Manage and Install Plugins.

Manage and Install Plugins

The Plugins dialogue can be used to:

Find and install new plugins

Activate and deactivate installed plugins

Upgrade plugins

Remove plugins

The quickest way of finding a plugin which meets your needs is to use the Search dialogue - this will
search incrementally in plugin names and descriptions.

 All

This tab shows all available plugins, including those installed. There will probably be around 500, but the
number will change over time, and will vary according to the  - see below.Settings

Click on a name to see details.

You can change the sort order by right-clicking on an plugin name

To download and install a plugin, click on its name and click Install plugin

Installed

This tab shows a list of all plugins currently installed.

This includes plugins will have been installed by QGIS, and those you have added

To activate or deactivate a plugin, click its checkbox or double click its name

Plugins in red are not loaded because there is a problem.

Upgrade all installed plugins by clicking Upgrade all
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Not Installed

This tab shows all plugins available in the repository but not installed.

Upgradeable

This tab shows installed plugins where there is an upgrade available.

Settings

 In the  tab, you can:Settings

Change the frequency of checks for updates

Include experimental plugins (often useful, but may not be suitable for production use)

Add additional repositories - there is an official repository, but there are also others

Recommended Plugins

A list of plugins you may find useful is included elsewhere in these notes (see Table of Contents).
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2. Vector Data in QGIS

2. Vector Data in QGIS
2.1. Introduction

2.2. File-Based Vector Data
GeoPackage

ESRI Shapefile

MapInfo

Other

2.3. Spreadsheet Data
Excel

Delimited Text Data (e.g. CSV)

2.4. Database Layers

2.5. Web Feature Service (WFS)
Layers

Create a new saved WFS
Connection 

Connect to the WFS 

2.6. Navigating Vector Layers
View Layer Extents

Attribute Table

Manage the Layer List

Group Layers 

Remove Layers

2.7. Joining Layers

2.8. Exporting Vector Data

An Astun Technology QGIS Training Module

Code QGIS-02

Title Vector Data in QGIS

Description Load, join, and export vector
data

Required
Software

QGIS v 3.0 or later

Target Audience QGIS Desktop users

Updated 09 Apr 2018  

Updated by Antony Scott

Status In progress

2.1. Introduction

QGIS can open around 50 file-based data formats (using the  library), including ESRI shapefile andOGR
MapInfo TAB, and can save around 20 of these. It can also connect to five spatial database sources
natively, with others available using ODBC, and to  data.Web Feature Service (WFS)

Since QGIS 3.0, the default file format is , and in effect (though not  explicitly) forOGC GeoPackage
databases the default connection is to . PostGreSQL/PostGIS

Most QGIS functionality is available for all vector data sources, though some can only be used in read-only
mode and need to be saved to another format for editing.

2.2. File-Based Vector Data

https://astuntech.atlassian.net/wiki/people/557058:c1a4281b-182c-4434-8cc5-337ef0a7929e?ref=confluence
http://www.gdal.org/ogr2ogr.html
http://www.opengeospatial.org/standards/wfs
http://www.geopackage.org/
https://postgis.net/
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1.  

2.  

3.  

1.  

2.  

GeoPackage

GeoPackage is relatively new - it was first published as an OGC standard in 2014, and the current version,
1.1, was published in 2016. It has a .gpkg file extension, and although it can be used for single layers, it is
implemented using the SQLite database standard, so can hold multiple layers in a single file as well. It is
supported by current versions of most desktop GIS packages, and although it has not been widely used
until now, it should be set to take over from shapefile as the default file-based storage and interchange
format across applications and platforms. It will hold raster as well as vector data.

To load a GeoPackage layer:

Click Open Data Source Manager 
Browse to the .gpkg file you want to open (this will be in .../Data/Vector under root directory for the
course)

Double-click or drag and drop to open the layer in QGIS

ESRI Shapefile

Until version 3.0, shapefile was the native format for QGIS, and it is still used by ESRI products (for
example ArcGIS) and on many download sites. Shapefiles comprise four or more individual files on disk -
all must be available for the file to open.

To filter directory listings to shapefile (or any file vector format):

Click Open Data Source Manager

Click the  tab on the left of the dialogVector

Layer metadata
Right-click > Properties on the layer in the browser to see its metadata - CRS, number of features,
fields and so on.
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2.  

3.  

4.  

Click the three dots (...) to the right of the  field, then use the dropdown to the rightVector Dataset(s)
of the  field to filter to .shpFile name:

The list of files will be filtered to .shp only

MapInfo

QGIS can open both MIF and TAB files - these will appear in the browser with other file-based data. Note
that MapInfo files can contain multiple geometry types, so QGIS may present a dialog with a choice of
geometry types - i.e. line, polygon, point - to load. You can filter to MapInfo files in the same way as
described for shapefiles above.

Editing MapInfo files
QGIS can edit .tab but not .mif files - if you need to edit these, you will need to save them to a
different format (for example GeoPackage), then save back when you are finished.
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1.  

2.  

3.  

1.  

2.  

3.  

Other

The process above can be used to load most vector data from file, including for example GML, GPX and
GeoJSON. QGIS can also open ESRI GeoDatabases, though these will be read-only.

2.3. Spreadsheet Data

QGIS hasn't always worked well with native spreadsheet data (for example from Excel), but this has
improved over time, and QGIS 3.0 will now open an Excel file, and for the most part correctly recognise
data types (for example string, integer and so on). If the data includes coordinates, creating a geometry
column which QGIS can use to represent the data spatially requires an extra step. In some cases, it's better
to load the data as CSV rather than directly from Excel - you will need to see what works best with a
particular dataset.

Excel

To load data from Excel:

Click Open Data Manager
Browse to the Excel file

Double-click to add the layer to QGIS

At this stage, the layer will show in the  panel as a table , but itLayers
won't appear on the map. If the data doesn't contain coordinates, this may be what you want. However if
the data represents points, and you have an x and y column, you will need to add a geometry column to the
data so that QGIS can add it to the map.

Set the  to the CRS of the coordinates in your input data - you need to do this first, as Project CRS
you can't choose the CRS later

In the search bar, search for geometry

Double-click on , and in the dialog, choose the appropriate layer andExport geometry columns
Project CRS
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3.  

4.  

5.  

1.  

2.  

3.  

Click Run in Background

The layer will appear in the  panel as , and the points will appear on theLayers Added geom info
map

Delimited Text Data (e.g. CSV)

If you need more control over the process of loading spreadsheet data, or if it's already held in delimited
text such as CSV, you can use the  Add delimited text layer tool.

Click Open Data Source Manager

Select the  tab to bring up the  dialog Delimited Text Delimited Text

Adjust the settings shown below if necessary - note that in this instance, only the  settGeometry CRS
ing was changed from the default - QGIS derived all other settings from the data

Adding geometry to Excel data
This approach will only work if the coordinates in the data are held in columns with names that
QGIS will recognise - for example  and  for British National Grid data, or   foreasting northing lat long
WGS84 data, If this isn't the case, you will need to save the Excel data as CSV, and follow the
procedure below.
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3.  

4.  Click  to add the layer to the mapAdd

Saving CSV in a vector format
At this point you may want to save the CSV as a standard vector format - there are some things
which can't be done while it's still held as CSV. On the other hand, if you are using a CSV which is
regularly updated from an external source, you may want to keep it as CSV, so that QGIS is always
looking at the latest version of the data.
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1.  

2.  

3.  

If the data has no coordinate data, and is just going to be used in QGIS as a table, check the Geometry
 option in the dialog abovedefinition > No geometry . This is useful, for example, if there is a layer that

needs to be joined.

If the file has a column containing  data (e.g. "SRID=27700;POINT(507417Well Known Text (WKT)
163699)" ) instead of coordinates, check the  option.Geometry definition > Well known text

2.4. Database Layers

Loading database vector layers follows a slightly different process to loading a file-based layer, as you first
need to establish a database connection. The process is similar for all databases, but in this example we
will use data in a PostGreSQL database.

To load data from a PostGreSQL database:

Click Open Data Source Manger

Click the  tabPostgreSQL

If you haven't connected to the database before, click  to create a new database connectionNew

Database layers
You can load either spatial or non-spatial data from a database - the non-spatial data will be shown
in QGIS as a table, which you can join to spatial data as shown below.

https://en.wikipedia.org/wiki/Well-known_text
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3.  

4.  
a.  

b.  

c.  

d.  

5.  
a.  

Complete the dialog:
: your name for the connectionName

: the name or IP address of the server the database is running onHost

: the port the database is running on - by default in PostGreSQL this is 5432, but it couldPort
be different

: the name of the database you want to connect toDatabase

Under , click the  button to add your credentialsAuthentication Add
The first time you do this, you will be prompted for a  - Master password make sure this is
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5.  
a.  

b.  

c.  

d.  

something you can safely store or remember, as it cannot be retrieved later

Once you have done this, you will be able to set the credentials for this connection:

Click  to save these credentials, then click  to make sure the connectionSave Test Connection
is OK

If all is well, click , then click  to establish the connection with the databaseOK Connect
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5.  

d.  

e.  

f.  

Expand the database schemas, and select a table and click  to add it to the mapAdd

Check  to view non-spatial data tablesAlso list tables with no geometry

Once the data is loaded in the  panel, it will behave in the same way as file-based vector layers. YouLayers
only need to set up the connection once - after that, you can connect to the database from the PostGreSQL
table in the , or from the  tab.Data Source Manager Browser

2.5. Web Feature Service (WFS) Layers
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1.  

2.  

a.  

b.  

c.  

3.  

1.  

2.  

Data available in   format can be loaded in QGIS and used in a similarOGC Web Feature Service (WFS)
way to any other vector layer. However as the data is online, an Internet connection is required to use WFS
data, although once the connection has been made it can be saved locally. WFS data is supplied as GML,
and features can be selected, styled and queried in the same way as any other vector data. 

To use a WFS, click the  tool from the  toolbar.Add WFS Layer Manage Layers

Create a new saved WFS Connection 

The first time you have connect to a WFS source, you will need to create a connection:

Click , then the  tabOpen Data Source Manager WFS

Click , then in the  dialog, add the connection details.New Create a New WFS Connection

Name: your name for the connection

URL: the URL of the WFS, for example https://ons-inspire.esriuk.com/arcgis/services/Other_Bo
?undaries/National_Parks_August_2016_Boundaries/MapServer/WFSServer

Authentication: complete as required

Click .OK

Connect to the WFS 

Select the saved WFS

Click to show the layers available in tConnect he WFS

http://www.opengeospatial.org/standards/wfs
https://ons-inspire.esriuk.com/arcgis/services/Other_Boundaries/National_Parks_August_2016_Boundaries/MapServer/WFSServer
https://ons-inspire.esriuk.com/arcgis/services/Other_Boundaries/National_Parks_August_2016_Boundaries/MapServer/WFSServer
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2.  

3.  

4.  

5.  

Select the layer(s) required - you can select multiple layers

Click to load the layer(s) into the mapAdd 
Note that with large datasets, it can take some time for the layers to load

WFS Queries
By default, only features within the current view extent will be downloaded - uncheck Only

 to load all features from the sourcerequest features overlapping the view extent

To load only a subset of features (other than by extent), click  to bring up the  Build query SQL
, and add a query to select the features you needQuery Composer
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1.  

Once WFS layers are loaded, they can be managed in the same way as other vector layers.

Transactional Web Feature Service (WFS-T) layers, which are editable, are also supported in QGIS.

2.6. Navigating Vector Layers

There are different approaches to navigating around the layers you have loaded, for example using
toolbars, mouse actions and menus - some of the key ones are listed here.

The buttons in the  Toolbar will also get you around the map, and change the action ofMap Navigation
your mouse and cursor - these will help you identify the data and views you need.

View Layer Extents

When a layer has been added to the Layers panel, the features will be visible in the map frame on the right.
To see the whole layer in the frame:
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1.  

2.  

1.  

2.  

3.  

1.  

2.  

3.  

4.  

5.  
1.  

Click on the layer to select it

Right-click > Zoom to Layer (or click the icon on the toolbar)

Attribute Table

You can browse the attribute data for each layer by right-clicking on the layer and selecting Open Attribute

Table, (or click the  icon in the toolbar). 

Manage the Layer List

Normally, layers at the top of the list in the  panel appear on the map in front of layers further downLayers
the list. You can change the order of layers in the list by dragging and dropping layers to a new position.

Group Layers 

Layers can be grouped to create a hierarchical layer list, or table of contents.

Click the  button at the top of the  panel Add Group Layers

Right-click and the new groupRename 
Drag and drop layers into the group

 

Remove Layers

To remove a layer from the list, select the layer, then Right-click > . This does not delete the data,Remove
just removes it from the map. However you will lose any styling or queries you have applied to the layer.

2.7. Joining Layers

If you want to use data in your map which has no spatial references, you will need to  this to ajoin
corresponding spatial dataset. For example, you might have population data for census areas, and a
polygon layer of the census areas themselves, and you want to join the two in order to show the population
figures for each areas as a label.

Add the non-spatial data table, and the spatial layer you are joining it to, as described earlier

The new table will appear in the  panel, but not on the mapLayers

Double-click the spatial layer to bring up the  dialog, and select the  tabProperties Joins

Click the  button bottom left Add to add a join 

In the  dialog, use the dropdowns to specify:Add Vector Join
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5.  
1.  

2.  

3.  

6.  

1.  

: the layer you want to join to the current oneJoin layer

: the field in the target layer (the one you are joining to) that is going to be used forJoin field
the join (this might be ID, for example, or name, or in the case below, neighbourhood)

: the field in the current layer (the spatial one) which is going to be used for the joinTarget field
- this must contain the same data as the join field

Click  and  again, then check the attribute table of the spatial layer - it will have an expandedOK OK
number of columns to include the data from the non-spatial table

2.8. Exporting Vector Data

To export a layer or part of a layer:

 from the layerRight-click > Save as

Join definition
The join definition is saved in memory, and is saved in the QGIS project - it does not affect the
source data. It will therefore reflect the current data each time the project is loaded. You can edit the
join after it has been created - for example to exclude fields from the joined data - in the same dialog
you used to create it.
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1.  

2.  

1.  

2.  

3.  

4.  

5.  

In the dialog, you can simply save the file as a different name - however you can also use other
options:

Format: save the data in a different vector format

Save only selected features: save a subset of the features

CRS: reproject the data on save to a different CRS

Select fields to export: save a subset of fields from the attribute table

Extent: save only features visible in the current extent

Exporting a joined layer
If you export a layer with a join, the exported data will include the fields in the join - this is a way of
creating a permanent new dataset from a joined layer.
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3. Styling in QGIS

 

3. Styling in QGIS
3.1. Introduction

3.2. The Style Dialog

3.3. Symbology Types
Single Symbol

Categorized

Graduated

3.4. Re-using Styles

3.5. Images

3.6. Labels

An Astun Technology Training Module

Code QGIS-03

Title Styling in QGIS

Description Add styles and labels to layers

Required Software QGIS v 3.0 or later

Target Audience QGIS Desktop users

Version 1.0

Updated 27 Feb 2018 

Updated by Antony Scott

Status In development

3.1. Introduction

We need to add style to data to give it a useful representation on the map. Styles can be very simple (for
example 'colour everything blue'), to highly complex with multiple rules and elements. This module covers
some basic styling approaches and techniques, with some pointers to more advanced techniques.

3.2. The Style Dialog

QGIS applies a default style to every layer when it is loaded (otherwise layers would not be visible). To set
your own style, you can access Symbology for the layer in the Layer Properties dialog, but it's usually
more convenient to use the style dock, which allows you to set styling for all layers from a dockable panel,
and updates changes live on the map.

To use the style dock:

Click the button at the top of the Layers panel , or hit F7

Select the layer that you want to style from the first dropdown

Select the type of symbology you want to apply from the second dropdown

https://astuntech.atlassian.net/wiki/people/557058:c1a4281b-182c-4434-8cc5-337ef0a7929e?ref=confluence
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The symbology options are as follows:

Symbology
type

Description Example Comment

No symbols The layer will not appear on the map. Display the
data using
labels only

Single
symbol

The same symbology will be used for
all features

Location of
villages

Symbol can be sized
proportionately to an attribute
value - for example population
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Categorized A different symbology will be used for
each unique value of an attribute

Crime
types

Depending on values, each
feature could have a unique
style, or features could share the
same style

Graduated For numeric data only, values can be
'banded', with each band having a
different style, usually using a
graduated colour ramp

Voting
patterns

Number, size and statistical
composition of bands can be set
by user

Rule-based One or more rules (or queries) can be
used to determine styling

Ordnance
Survey
MasterMap

Used to apply more complex
logic to styling, for example
where the content of more than
one attribute is used to determine
style

Point
displacement

Move points slightly if they are in the
same location, or within a set tolerance
of each other, so that they are all visible

Crime
locations

Where representation of numbers
is more important than
geographical accuracy

Point cluster Coalesces points which are in the same
location or within a set tolerance of
each other into a single symbol, with a
number showing the count of the points
included

Crime
locations

Where representation of numbers
and geographical accuracy to a
certain zoom level is required,
with numbers of points coalesced
changing with zoom level

Heat map Continuous surface of varying colour
and intensity based on point density

Bird
nesting
locations

Best used to visualise point
locations over an homogenous
area

This module focuses on Single Symbol, Categorised and Graduated.

3.3. Symbology Types

Single Symbol

Where a dataset is homogenous, and/or you want to represent all the features in the same way, use Single
. Despite the name, this style type can be used for lines and polygons as well as points, and thesymbol

styling options will depend on which of these geometry types you are styling.

QGIS always provides some pre-packaged styles, so you can use these and amend them, or build your
own from scratch. Styles can contain one or more elements - for example in the screenshot below there is a
single . Click on the existing styles to see how these are typically constructed.Simple marker
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To change a style, click on one of its components,  for example the  in the screenshotSimple marker
above. This shows settings which are specific to that component - for example colour, size and stroke style.
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Click the  button   to add components to the style, and use the up and down arrows to control whichadd
components are in front or behind.

Live update
The  checkbox at the bottom right of the dialog keeps your style changes in synch withLive update
the map. If this is slowing things down too much, uncheck it and use the  button when youApply
want to see the effect of your changes.
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1.  

2.  

3.  

1.  

2.  

3.  

4.  

Categorized

A categorized style is used to classify the map based on unique attribute values in the dataset.

To apply a categorized style:

Select  from the dropdown listCategorized

Select a  to use for the categorizationColumn

Click  to apply the colours in the  to the valuesClassify Color ramp

You can edit the individual class styles:

Right-click on one of the styles to get a limited set of options (e.g. colour, size, opacity)

Double-click to see the full style dialog

You can also double-click on the text under the  heading to change it.Legend

Graduated

Graduated styling requires numeric attribute values, and places them within ranges, each of which will be
styled differently. The example below uses neighbourhood crime data, showing the number of vehicle
crimes in one month per neighbourhood.

To apply a graduated style:

Select  from the dropdown listGraduated

Under  select the field with the relevant data that you want to representColumn,

Click  to create the class bands and apply the Classify Color ramp

Adjust the settings and click  again if requiredClassify
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4.  

3.4. Re-using Styles

There are a number of ways to re-use a style. You can:

Copy/paste styles between layers: select the layer,  (or )right-click > Copy Paste

Save a style in the QGIS native file format, .qml, for importing to another project: double-click the
layer > Layer Properties > Symbology > Style > Save Style > QGIS Layer Style File

Save a style as an  , for use in other applications which support it: SLD (Styled Layer Descriptor) doub
le-click the layer > Layer Properties > Symbology > Style > Save Style > SLD File

Load a style from QML or SLD: double-click the layer > Layer Properties > Symbology > Style >
Load Style

Create and import style libraries (groups of styles) for example for corporate use: Settings > Style
Manager > Import / export

Set a style as a default, to be used when a layer is added to a project. This works well if the layers
are stored in a PostGreSQL database, as the default styles are available to any user. File-based
default styles are normally only be available to the local user: double-click the layer > Layer

QGIS and SLD
QGIS does not at the moment fully support the SLD standard in its export and import - there
are some styles which will not be translated. You may also need to do some tweaking of the
SLD file (which is in XML), depending on the application you are working with.

http://www.opengeospatial.org/standards/sld
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Properties > Symbology > Style > Load Style > Save as default 

3.5. Images

QGIS uses  images as its native image format - other formats such as PNGScalable Vector Graphic (SVG)
and JPG can be used if they are embedded in a SVG file. Graphics programs such as  canonly  InkScape
be used to create SVG images. Images can be used in all geometry types - for point styles, for area fills,
and for markers on a line. SVG images can be coloured and scaled, and combined to create composite
images, so they are more versatile than some other formats.

To use an SVG image:

In the  dialog (where a specific symbol is configured), from the Symbol Selector Symbol Layer Type
dropdown list select SVG marker

https://www.w3.org/Graphics/SVG/
https://inkscape.org/en/
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Select the SVG marker to use from the library, or use the file manager view to browse to your own
SVG image

Adjust the settings such as size and colour to suit your needs
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3.6. Labels

Labels are also configured from the  dialog (the Style Dock). To activate the labels dialog:Layer Styling

Click the button at the top of the Layers panel , or hit F7

In the Layers dropdown, select Show labels for this layer
In , select the column to be used for labelsLabel with

You can now adjust a range of settings for labels, including font, placement and formatting. 

We are not going to cover label settings in detail, but here are a few pointers and tips:

If some labels are not appearing on the map, this may be because they are conflicting with other

labels and so have been removed. Use  in the  tab Show all labels for this layer Rendering
 so you can see all labels

Use the settings in the  tab  to draw a buffer or halo round labels so they stand outBuffer
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against a darker background 

Use the  button    (next to the  field) to build labels withExpression Builder  Label with
expressions - for example concatenating two or more attribute values, or creating a total of numeric
values
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4. Select and Filter in QGIS 

4. Select and Filter in QGIS 
4.1. Introduction

4.2. Identify Features
Derived Information

Multiple Features

Feature Attributes

Identify Features from Multiple Layers

4.3. Selection
Select Feature(s)

Select Features by
Polygon/Freehand/Radius

Navigate and Remove Selection

4.4. Using the Attribute Table

Attribute Table Views

Toggle Attribute Views

Attribute Table Field Filter

Attribute Table Advanced Filter
(Expression)

4.5. Filter (Layer)

4.6. Spatial Selections and Filters
Select by Location

Join Attributes by Location

An Astun Technology QGIS Training Module

Code QGIS-04

Title Select and Filter in QGIS

Description Select, query, filter,
expressions.

Required
Software

QGIS v 3.0 or later

Target Audience QGIS Desktop users

Updated 01 Mar 2018 

Updated by Antony Scott

Status In development

4.1. Introduction

QGIS provides a number of different ways of selecting, filtering and querying map layers. It's important to
understand the terms that QGIS uses to describe these different techniques - they are summarised in this
table.

Action Result How Details

Identify Show data (attribute values) for a single feature
or group of features, and optionally show values
in a form for viewing/editing. Attribute data is
shown for each feature, along with derived data
- e.g. length/area.

Click the Identify
 button, thenfeatures

click on a feature.

Select Create a subset of tagged (selected) features
from one or more layers, while continuing to
display all features. Selected features are
highlighted in the map and attribute table.
Further actions (e.g. save, processing) can be
performed on the selection only.

Click on one of the Sel
 buttons, or useect

their dropdowns, to
make a selection.

https://astuntech.atlassian.net/wiki/people/557058:c1a4281b-182c-4434-8cc5-337ef0a7929e?ref=confluence
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1.  

2.  

3.  

Filter
(layer)

Display only a subset of the features in a layer
(inlcuding both map and attribute table), hiding
the rest.

Layer > Filter Write a query to filter
features.

Filter
(attribute
table)

Display a subset of features in the attribute
table, without changing the map. 

Layer > Open
Attribute Table
> Field Filter or 
Advanced Filter
(Expression)

Write a query to filter
features.

The  and  tools are grouped together in the  toolbar, and additional tools are in theIdentify Select Attributes
 toolbar, shown in the second row below.Attribute Table

4.2. Identify Features

The  tool  Identify Features is used to display the attribute values,  and some derived properties of a map
feature. 

Click the layer of interest in the layer list

Click the button - the cursor will changeIdentify Features 
Click on a map feature.



Commercial in Confidence 45 of 154 Copyright 2018 Astun Technology Ltd. All rights reserved.

3.  

4.  

 

The feature will be highlighted, and the Identify Results panel box will appear, showing the values of
all the attributes for the feature

Derived Information

The  section in the panel Derived includes measurements derived from the geometry of the feature such as
length, area and perimeter (depending on the geometry type).

Multiple Features

If you click close to feature boundaries, multiple features are identified, and these will be listed as separate
items in the  hierarchy. Browse the tree to see the data for each feature.Identify Results

Feature Attributes
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To view the attributes for a feature in a form dialog, click the  button at the top of theView feature form  Ide

 panel . This makes it easier to view the data, and if the layer is in edit mode, to edit it.ntify Results

To open the form automatically whenever  is used, check the  box at theIdentify Results Auto open form
bottom of the panel.

Identify Features from Multiple Layers

If you click on a location where there are features from multiple layers, you will be able to choose which
layers to use in populating the   panel (including all of them).Identify Results

To show results for a single selected layer, select  from the  dropdown at the bottom ofCurrent layer Mode
the  panel.Identify Results

Copy to clipbboard

The  button  copies the data from the clicked feature toCopy Selected Feature to clipboard
the clipboard as tab delimited text - you can then paste it to a text editor or directly into a
spreadsheet.
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4.3. Selection

Selecting features 'tags' them for future use, highlighting them in the map and in the attribute table. It also c
reates a subset of the data that QGIS can use to apply specific functionality to - for example, once features
have been selected, you can:

save the selected features as a new layer

run processing tasks on them

invert the selection to select all features currently not selected.

Features can be selected:

interactively in the map interface, for example by clicking or selecting by rectangle

interactively in the attribute table, by clicking one or more rows

by query, from the map or attribute table

To select interactively from the map, click the dropdown (the black triangle) next to the Select features by

 button in the toolbar . The menu which appears gives you a number ofarea or single click
options:

Select Feature(s)

Click  (it's selected by default), then click on the map to select a single feature at thatSelect Feature(s)
location. Use  to select multiple features.Ctrl-click
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You can also click and drag a box over features to select all features that intersect the box.

Select Features by Polygon/Freehand/Radius

Use these tools to select features by drawing a polygon, freehand line or radius:

by polygon

freehand
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radius

Select Features by Value or Expression

The tools on the  dropdown allow you to identify a selection by using aSelect Features by Value
query, or by matching values against attributes.

 displays a dialog where you can enter values to search for in the data -Select Features by Value
note that the search is interactive, so as soon as you start typing, matching values appear
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 displays a dialog in which you can build a query by selecting fields, operatorsSelect by Expression
and functions. This dialog appears in a number of places in QGIS, and it will be explained in more
detail below

Navigate and Remove Selection
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Navigate to a selection in two ways:

 will centre the map on the feature Pan Map to Selection

 will set the map extents to match those of the feature Zoom to Selection

To remove selections:

Deselect Features to deselect features from all layers 

4.4. Using the Attribute Table

The attribute table holds data about all the features in the layer - you can use it to view, edit and query
data. Open it from the  toolbar, or by  from a layer in the layerAttributes right-click > Open Attribute table
list. Each row in the attribute table corresponds to a feature on the map, and selection is synchronised
between the table and the map - if a feature is selected in the attribute table, it's also selected on the map.

Attribute Table Views

The  button at the bottom left of the attribute table is a button which has a dropdownShow All Features
with a number of options to control which features appear in the table:

Show All Features: Show all features in the data

Show Selected Features: Only features selected in the map/table will be shown

Show Features Visible on Map: Only features which can be seen in the current map window are
shown

Show Edited and New Features: During an editing session, this shows features which have been
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created or edited but not yet saved

Field Filter: filter the table by selecting a field and a search value

Advanced Filter (Expression): filter the table by opening the  dialogExpression based filter

Toggle Attribute Views

There are two possible views of the data within the attribute table - the default tabular or grid view, and the
form view. Switch to the form view and back by using the buttons at the bottom right-hand side of the
window.

The form view is similar to the form used in , but includes a navigation panel on the left for Identify Results
moving between features. This can be more convenient for editing attribute values.

Form view
Select features in the form view of the attribute table by clicking the checkbox to the left of the
feature list - once selected, the box for the feature will show yellow. 
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1.  

2.  

3.  

4.  

Attribute Table Field Filter

Run a simple search in the attribute table by selecting  from the menu in the bottom left of the Field Filter at
tribute table dialog, then select the column name for the search. This is a simpler, single field version of the 

 tool described above, and it will show matching values interactively in the same way. ToSelect by Values
run the search, press .Enter

The attribute table will be filtered to show only the matching features.

Attribute Table Advanced Filter (Expression)

Select  from the dropdown at bottom left of the attribute table to Advanced Filter (Expression) open the Ex
 dialog - this is the same one as opened from  earlipression Based Filter Select Features by Expression

er. However the result of applying this expression will only filter features in the attribute table, not on the
map.

Queries can be built up in this dialog by selecting fields, operators, values and functions. For example, a
simple query might be in the form:

[field] [operator] [value] - e.g. phase_of_education = 'Primary'

The example below builds a simple query to find all all parishes which are 'filler areas' - i.e. where there is
no council.

In the  dialog, navigate to  in the central panel and selectExpression Based Filter Fields and Values
the relevant field (in this case descript0)

Double-click on the field to bring it into the  panel on the leftExpression

Click on the  operator in the  panel= Expression

In the  panel, click  to show all the values of the field which appear in the data (or ifValues all unique
there are a large number of values, click )10 samples

Case sensitivity
Values are not case sensitive unless the  box is checked, and the search is for aCase sensitive
pattern within the string (for example  will find ) so you don’t need the exact value.ming Birmingham

Datatypes
Here, and in many other field-specific locations, there is an indicator of datatype immediately before
the field name. For example,  means a text field, while  means numeric.abc 123
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5.  

6.  

Double-click on the value you want to use for the filter (in this case 'FILLER AREA')

You should now have an expression in place which looks something like the screenshot below - click 
 to apply the filterOK

Operators

The operators below are the most commonly used, but more are available in the dialog.

Operator Meaning

= Equal to

<>  Not equal to

< Less than

> Greater than

<= Less than or equal to

>= Greater than or equal to

LIKE Case-sensitive string match
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1.  

2.  

3.  

ILIKE Case-insensitive string match

NOT Combined with another operator to make it negative

% Wildcard – include in the search string at the point of uncertainty

AND Extends queries to apply more than one condition to a search

OR Extends queries to search for different values and will be returned if either is true

|| Join two values into a string

4.5. Filter (Layer)

When a layer is filtered,  the filtered features are visible - the user will not see any that do not meet theonly
filter conditions, either on the map or in the attribute table.

To apply a filter:

Select the layer to be filtered

 > Right-click Filter

In the  dialog, construct a query to show the features you needQuery Builder

The  dialog is similar but not identical to the Query Builder Expression Based Filter dialog described
above. 

To reset the query in order to see all data, click  in the .Clear Query Builder

4.6. Spatial Selections and Filters

The queries and expressions we have been looking at until now work by using the attribute values of layers
rather than their geography. There are a number of options for running spatially-based queries in QGIS,
addressing questions such as:

Which points fall within this polygon?

Which lines cross this boundary?

What are the distances between features?

Two approaches are covered here:

Selecting features based on location

Join attributes by location

Select by Location

This tool creates a new selection of features in a layer, based on a spatial relationship between the layer
and another layer (or even the same layer). For example you might want to use it to:

Spatial queries
There are many types of spatial queries - use the search box at the left of the information bar to look
for others.
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1.  

2.  

3.  

select points in a polygon

select lines which intersect a polygon

select a polygon which contains a specific point.

To select points in a polygon:

Select the polygon you want to make the selection within - in this instance we have selected a parish
within which we want to identify crimes

In the search box, search for , then double-click on it to bring up the dialog Select by location

In the  dialog, complete the options in a similar way to the screenshot belowSelect by location
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3.  

4.  
a.  

b.  

c.  

d.  

5.  

6.  

Note that:
The first layer should be the one which contains the things you want selected - e.g. crimes

The  determines the spatial relationship between the features in the two layerspredicate
The second layer is the one you are using to drive the selection - in this case parishes

The  checkbox specifies that only selected features in the second layer Selected features only
will be used to make the selection - in this case it's the single feature we selected in the first
step

Click  to run the selection - the result will be a map which looks something like this:OK

Note that only crimes  the selected parish have been selectedwithin

Join Attributes by Location
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1.  

2.  

3.  

4.  

This tool carries out a similar operation to the one above, but instead of making the result a selection, it
adds the attribute values of the second layer to the first, target layer, so that each feature which satisfies
the criteria in the spatial analysis takes on the attributes of the feature it is within (in this case).

As in the previous example, select a polygon you want to make a selection with

In the search box, search for Join attributes by location
Open the dialog, and complete in a similar way to the screenshot below:

When the process is run a new  will be created and added to the map, comprising theJoined layer
original crime layer with, for each feature, the attributes from the parish it is within
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4.  

5.  This layer can then be retained as a temporary layer in the project, or saved as a new layer
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5. Raster Data in QGIS

 

5. Raster Data in QGIS
5.1. Introduction

5.2. File Types
Georeference files

5.3. Loading Raster Images

5.4. Virtual Rasters

5.5. Web Map Services (WMS)
Create a New WMS Connection

Connect to the WMS

5.6. Raster Style

An Astun Technology QGIS Training Module

Code QGIS-05

Title Raster Data in QGIS

Description Working with raster data

Required Software QGIS v 3.0 or later

Target Audience QGIS Desktop users

Updated 28 Mar 2018 

Updated by Antony Scott

Status In progress

5.1. Introduction

Raster data is fundamentally different from vector data - whereas vector data has discrete features
constructed from vertices, raster data is a digital image, where the shapes represented are constructed
from cells or pixels, with a single numeric value per pixel (often represented as a colour) - they don’t exist
as separate selectable or queryable features.

5.2. File Types

While it is possible to add most raster formats in QGIS, for images to be displayed at the correct location,

https://astuntech.atlassian.net/wiki/people/557058:c1a4281b-182c-4434-8cc5-337ef0a7929e?ref=confluence
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1.  

2.  

projection and location information is required. In some formats, such as GeoTIFF or ECW, this is included
within the file.  For other formats, a separate geo-referencing file is required for each image.

To see which raster formats are currently supported by QGIS, click , then the  tOpen Data Manager Raster
ab and browse. The file filter lists all possible raster formats (currently over 70) - QGIS uses GDAL for file
conversion, so formats supported by GDAL are supported by QGIS.

Georeference files

Files which don't have georeferencing data embedded should have separate georeference files. These
must have the same name as the image file, though the extension will be different, and be in the same
folder as the image file.

Example georeference file formats are:

TFW (ESRI World file)

TAB (MapInfo file)

For Ordnance Survey tiled raster data files for example, both formats are supplied as a separate fileset, and
need to be copied into the same folders as the images in order to be used. Other image suppliers provide
similar files.

5.3. Loading Raster Images

To load a single raster image or a small number of files:

Click , then  .Open Data Manager Raster
Browse to the file, using the file filter to show only files of a specific type if needed. Be sure to select
the file itself, not the georeference file.

Multiple files
Use  or  to load multiple files at the same time. Ctrl-click Shift-click
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2.  

3.  

4.  

1.  

2.  

3.  

4.  

5.  

Once you have selected the file(s), click  to load them as layers in the map.Add
Check the layer list and the map to see that the tiles have loaded correctly.

Note that each image loads as a separate layer. When there are a large number of images, you can make
this easier to manage by either putting images in a group, or by creating a .Virtual Raster

5.4. Virtual Rasters

A virtual raster stitches raster images together so that they behave as though they were a single layer. For
a set of images at the same scale which provide coverage of a defined area, this is usually the optimal
format to use.

To create a virtual raster:

Go to .Raster > Miscellaneous > Build Virtual Raster

Click the three dots under  to select the files you want to include in the raster Input layers

In the  dialog, click , and browse to the location of the raster imagesMultiple selection Add file(s)
you want to include

Select all the images to be included - you may need to filter the view by type if there are
georeferencing files in the folder
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5.  

6.  

7.  

Your dialog should now look something like this

Click , uncheck  and set a location for the output file under , so your dialogOK Layer stack Virtual
looks something like this

Click  to create the virtual raster and load it into the mapRun in Background

The virtual raster layer will contain all the raster images in the directory, and once loaded it can be treated
in the same way as other raster layers.
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1.  

2.  
a.  

b.  

c.  

3.  

1.  

5.5. Web Map Services (WMS)

 is a standard protocol for serving raster data (e.g. map and aerial images)OGC Web Map Service (WMS)
over the Internet. Typically these will have been generated by map server software such as  or GeoServer

. To use a WMS you will need to know the URL of the service, and if required, logon credentials.MapServer

Create a New WMS Connection

The first time you connect to a WMS, you will need to create a connection:

Click , then the  tab, and  to create a new connectionOpen Data Source Manager WMS New

In the Create a new WMS connection window, add the connection details:
Name: your name for the connection

URL: the URL of the WMS (e.g. http://essex.astuntechnology.com/getows.ashx?mapsource=E
)ssex/Inspire_Tendring&version=1.1.1

Authentication: if required

Click - the connection uses the service of the WMS, which returns a list of theOK GetCapabilities 
available layers

Connect to the WMS

Select the required WMS and click Connect.

http://www.opengeospatial.org/standards/wms
http://geoserver.org/
http://mapserver.org/
http://essex.astuntechnology.com/getows.ashx?mapsource=Essex/Inspire_Tendring&version=1.1.1&request=GetCapabilities&service=WMS
http://essex.astuntechnology.com/getows.ashx?mapsource=Essex/Inspire_Tendring&version=1.1.1&request=GetCapabilities&service=WMS
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1.  

2.  

3.  

1.  

2.  

3.  

4.  

5.  

This connects to the WMS and lists the available layers

Select the layer required - note that these may be grouped hierarchically, you can select a layer, a
group, or load everything by selecting the top level

Click  to load WMS layers into the layer listAdd

5.6. Raster Style

Most background raster images (such as the Ordnance Survey ones used in this course) are already
styled. However you can amend the styling if required. For example, to change a raster to greyscale:

Open the  if it's not already openLayer Styling Dock
Select the layer to be styled

In the second dropdown, select Singleband gray

If necessary, adjust other settings - for example , , to improveColor gradient Contrast enhancement
the effect

The screenshot below shows the result for Ordnance Survey Vector Map District

WMS Layer Order
Select multiple WMS layers by using  or  - layers will be loaded as a singleCtrl-click Shift-click
combined layer.  You can change the order in which the individual layers appear by selecting the La

 tab in the WMS dialog.yer Order
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5.  

6.  Use the  tab if required to set the transparency of the layerTransparency
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6. QGIS Data Creation and Editing

 

6. QGIS Data Creation and Editing
6.1. Introduction

6.2. Create a New Layer

6.3. Edit Layer Geometry
Create Features

Edit Feature Geometry

Move a Feature

Snapping

Tracing

6.4. Edit Attribute Values
The Field Calculator

6.5. Edit Field List

An Astun Technology Training Module

Code QGIS-06

Title QGIS Data Creation and Editing

Description Creating and editing data

Required Software QGIS v 3.0 or later

Target Audience QGIS Desktop users

Updated 03 Apr 2018 

Updated by Antony Scott

Status In progress

6.1. Introduction

This module looks at creating and editing vector data, including both editing geometry in the map window
and editing attribute data in the attribute table and forms. 

6.2. Create a New Layer

Before you can add data, you need to create a layer to put it in. The example below describes how to
create a new GeoPackage layer - a file-based database format, which can hold more than one layer.
However you can also create layers in other formats - for example shapefile.

Click  New GeoPackage layer

Comp le te  t he   d i a l og :New GeoPackage  Layer

https://astuntech.atlassian.net/wiki/people/557058:c1a4281b-182c-4434-8cc5-337ef0a7929e?ref=confluence
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2.  

a.  

b.  

c.  

d.  

e.  
i.  

ii.  

iii.  

f.  

: browse using the three dots to the right of the field, and either choose an existingDatabase
GeoPackage, or create a new one with an appropriate location and name

: add a name for the layer (by default the name of the GeoPackage file) - this willTable name
appear in the layer list

: set the appropriate type from the dropdownGeometry type

: select the coordinate reference system for the layerCRS

: for each attribute in the layer, complete:New field
: a name for the attributeName

: an appropriate type from the dropdownType

 (where required): in number of characters, at least as long as yourMaximum length
longest value in the data

: when you have specified the details of each field (although you can addAdd to fields list
fields later)
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3.  

1.  

2.  

3.  

4.  

5.  

6.  

1.  

2.  

Click  to add the layer to the mapOK

6.3. Edit Layer Geometry

To edit a layer, select it in the layer list, then  or select the  tool Right-click > Toggle Editing Edit from the 
 toolbar.Digitizing

Note that edits are not saved to their source until you actively save them - use the button to doSave Layer 
this (you will be prompted to save when you use the  button Toggle Editing to stop editing).

Create Features

Create features in a layer using the  button in the  toolbar. This button variesAdd Feature Digitizing
according to the type of feature being created (e.g. points, lines or polygons) - in the screenshot below, the
button (fourth from left) is for creating new polygon features.

The individual points which make up features are known as .vertices

Add Points to a Layer

Select or create a point layer, and turn on editing

Click in the  toolbar, then move the cursor to required location Add Point Feature Digitizing and click

The attributes form will appear

Add the appropriate attribute values and click  (values can be added later if you prefer)OK
The new point will appear on the map

Save edits and turn off editing

Adding Lines and Polygons to a Layer

The process for adding lines or polygons is similar to that for adding points, but for each feature you need
to add a number of vertices.

In a line or polygon layer, click Add Feature
Click to add the first vertex

Undo
Ctrl-Z (undo) will reverse the last change you made, as long as you have not saved your edits.
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3.  

4.  

1.  

2.  

3.  
a.  

b.  

c.  

d.  

e.  

1.  

2.  

1.  

2.  

3.  

Continue clicking to add vertices

Right-click to complete the feature, and show the attributes dialog

Edit Feature Geometry

To modify the geometry of a feature, edit individual vertices. This is fairly intuitive (and easier to do than to
describe), but here are some instructions:

Turn on editing for the layer

Select the Vertex Tool
Hover over the vertex you want to edit, and:

: dcreate a new vertex ouble-click on the X which appears between two existing vertices

: click once on a vertex to select it, move the mouse to its new position, andmove a vertex
click again

: click on the vertex to select it, then click delete a vertex Delete

: click and drag a rectangle over the nodes to be deleted, then click delete multiple vertices D
elete

: click the segment to select it, move the mouse to itsmove a segment of a line or polygon
new position, click again

Move a Feature

To move a feature to a new position (without changing its geometry):

Click the  button Move Feature

Click and drag the feature to a new position

Snapping

Snapping allows you to create new features, or move existing ones, to align exactly with the coordinates of
another feature - for example to create a new boundary or building footprint which abutts or encloses an
existing one. When snapping is activated, any new vertices you create will snap to the coordinates of an
existing vertex in the target layer, if you click withing the tolerance settings.

To turn on snapping and define options:

Go to Project > Snapping Options to activate the  dialogProject Snapping Settings

Turn on snapping using the  on the lefttoggle snapping button

Set the layer you want to  using the  dropdown - if you want to snap to a specificsnap to Active layer
layer, you will probably need to select   to select itAdvanced configuration

Vertex tips
To delete the last vertex you created, use Backspace

If you double-click when digitising, two nodes will be created on top of each other – this is
best avoided.
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3.  

4.  

5.  

1.  

2.  

3.  

4.  

Select the appropriate layer(s), and set a  value - this governs the distance your cursortolerance
needs to be from an existing vertex before you can snap to it.

Continue editing - when you move the cursor within the tolerance settings of an existing vertex, it
shows a purple square, indicating that you are within snapping range

Tracing

As well as snapping, you can go one step further and trace features - i.e. replicate some or all the points on
a line or polygon in a new feature.

To turn on tracing, activate the Snapping Toolbar:

You need at least two layers: the one you are editing, and the one you are tracing, and you also need to
turn on snapping - the tracing tool will only follow lines in layers which have snapping turned on.

To trace over a polygon:

In the , click  (the right-hand button)Snapping Toolbar Enable Tracing
Move the cursor over the first vertex you want to trace, and click

Move the cursor over the last vertex of the section of the polygon you want to trace to, and click

All the points on the polygon in between your clicks will be digitised, and you can continue creating
vertices to create your new polygon

Snapping
Snapping setting stay in place until you change them.
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4.  

5.  In this example, the darker polygon has been created with three clicks

6.4. Edit Attribute Values

Attribute values can be edited directly in the attribute table, as you would in a spreadsheet. You need to
have editing turned on for the layer - this can be done in the attribute table itself.

With editing on, you can also use  Identify Features to select a feature and edit its attributes in a form.

The Field Calculator

The  creates new fields, or amends the values of existing ones, by using expressions. ForField Calculator
example, you could create a new field which totals the values of two existing fields.
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Open  by clicking the button in the attribute table toolbar. Field Calculator

Choose whether to create a new field or update an existing one, and use the expression builder to specify
the contents of the target field - in the example above, the total of all crime types.

As examples, you can use the  to:Field Calculator

: create a new field with the same type and length as the source field, with a newRename a field
name, and populate the new field with data from the old field

: use a data type conversion (under ) such as  Change data type Conversions to_int to change a
data type from string to numeric, for example

: in the  options, the  and  functions will return the coordinates ofDerive coordinates Geometry  $x $y
the points in a point layer
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6.5. Edit Field List

Fields can be added to and deleted from a layer in the  dialog.Layer Properties

Select the layer, then Right-click > Properties > Source  .Fields

Use the toolbar buttons to add and delete fields, bearing in mind that editing needs to be turned on to do
this.

Refactoring fields
You cannot change the name, type, alias or length of a field once it has been created, but you can
use the   algorithm to create a new layer with any required field changes.Refactor Fields
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1.  

7. QGIS Geo Processing

7. QGIS Geo Processing
7.1. Introduction

7.2. Geoprocessing Functions
Fixed distance buffer

Intersection

Difference

Union 

7.3. Other Tools
Polygon from Layer Extent

Random points inside
polygons

Vector grid

7.4. Analysis Tools
Distance Matrix

Sum line lengths

Count points in polygon

An Astun Technology QGIS Training Module

Code QGIS-07

Title QGIS Geo Processing

Description Processing and analysing vector
data.

Required
Software

QGIS v 3.0

Target Audience QGIS Desktop users

Updated 04 Apr 2018 

Updated by Antony Scott

Status In progress

7.1. Introduction

This module introduces a few of the common QGIS vector processing functions. In most cases, functions
take as input one or more vector layers and create a new vector layer as output. Many functions can be
accessed either through menus or by navigating in the - however the instructionsProcessing Toolbox 
below use the search bar ('omnisearch') as the easiest way of finding them.

7.2. Geoprocessing Functions

Fixed distance buffer

In the search bar, type  and select buffer Fixed Distance Buffer

https://astuntech.atlassian.net/wiki/people/557058:c1a4281b-182c-4434-8cc5-337ef0a7929e?ref=confluence
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1.  

2.  
a.  

b.  

c.  

d.  

e.  

f.  

Complete the dialog as follows:
Shapes: the layer to be buffered - to buffer a layer not currently in the map, browse to it using
the button to the right of the dropdown

Selected features only: buffer only the features in the source layer which are selected

Buffer distance: the distance in the units of the CRS of the layer (for example metres for
British National Grid) that the buffer should be from the source features

Number of buffer zones: increase this from one to create multiple buffers - i.e. to buffer the
buffers

Arc Vertex Distance: this controls the extent to which the buffer follows the shape of the
source line or polygon (it has no effect for lines) - normally the default is adequate

Dissolve Buffers: if checked, creates a single output multipolygon feature as shown below,
with any overlapping boundaries dissolved - if unchecked, a polygon is created for each source
feature
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2.  

f.  

g.  

h.  

i.  

j.  

k.  

1.  

2.  

Inner Buffer: for polygons, creates a buffer inside rather than outside the polygon - has no
effect for lines and points

Buffer: leave blank to create the output in memory, or browse to a location and enter a file
name to save the output

Open output file after running algorithm: load the buffer output into the map

Run as Batch Process: run multiple buffer processes as a single job

Run: create the buffer output

Intersection

This process creates an intersection of two sets of geometry - i.e. a new layer representing the shared
areas of the input layers.

In the search bar, type  and select the  toolintersection Intersection

Complete the dialog, and click  to add the intersect layer to the map - theRun in Background
screenshot below shows (outlined in black) the intersect between the green and the hatched layer
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2.  

Difference

The difference between two vector layers is represented by the areas which are in one but not the other - in
other words the inverse of intersection. The  tool has a similar dialog to the  tool,Difference Intersection
with two input layers specified.

Union 

The union tool merges the geometries from two layers into a single layer. Note that it does not dissolve
boundaries between features or create multi-polygons, but rather creates features comprising all
component parts from the two geometries. To use Union, search in the search bar.

If these are the features to be unioned:

 The result would be as follows:
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Note that separate features have been created where there is an overlap - in the screenshot below they
have been moved to demonstrate this:

7.3. Other Tools

As well as 'standard' geoprocessing functions, QGIS includes a range of useful tools that can be used for
research or other purposes - some examples are described here. In each case, use the search bar to load
the dialog.

Polygon from Layer Extent

This creates a rectangle (in black) that represents the maximum extent of all the features in a layer.
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Random points inside polygons

This is a sampling tool which creates randomly-located points in a new output dataset. This is commonly
used to create dot density maps.

The tool requires as a minimum:

an input polygon layer to define the area within which the points are created

a setting for the number of points to be created per feature, using an attribute in the source polygon
data - for example population
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The result will be something like this, with the number of dots based on the population of each area:
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1.  

Vector grid

A vector grid overlaid on a map can be used in analysis, for example showing the density of points within
grid squares, or for 'sectorising' an area.

Search for  and load the  dialogcreate grid Create grid
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1.  

2.  
a.  

b.  

c.  

d.  

3.  

Complete the dialog in a similar way to the example above:
Select  as the grid typeRectangle (polygon)

Use the three dots button to the right under  to set the extent to the current canvasGrid extent
Set the spacing values in metres for BNG

Click  to create the gridRun in Background

The grid will be loaded in the map - each square is a separate polygon
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3.  

1.  

7.4. Analysis Tools

The tools in this section support data analysis, both spatial and non-spatial.

Distance Matrix

This tool calculates the distances between all the points in one dataset and all the points in another, and
outputs the results to a new table.

For example, suppose we have two datasets, Places (A,B and C) and Destinations (W,X,Y and Z).

Search for  and open the dialogdistance matrix Distance matrix 
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1.  

2.  

3.  

Complete the dialog as appropriate, and click Run in Background

A table like the one below is created, showing distances between all points:

Sum line lengths

This tool calculates the total length of a line or line network within an area or multiple areas. Two input
layers are required; one containing the lines to be calculated, and the other the areas within which the
calculation will be made. The output will be a copy of the area layer, with the total line length within each
area as a new attribute.

Count points in polygon

This calculates the number of points in a point layer that fall within each feature of a polygon layer. It
requires two inputs; the point layer to be counted, and the polygon layer to count inside.

The output will be a copy of the polygon layer, with an additional attribute for each feature showing how
may points are inside it. This attribute can be used with a graduated style to indicate the frequency of points
in each feature.
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8. PostGIS Data in QGIS

8. PostGIS Data in QGIS
8.1. Introduction

8.2. Connecting to PostGIS

8.3. Load a PostGIS Layer 

8.4. Load Vector Layers into
PostGIS

An Astun Technology Training Module

Code QGIS-08

Title PostGIS Data in QGIS

Description Loading and saving PostGIS
data.

Required
Software

QGIS v 3.0 or later

Target Audience QGIS Desktop users

Updated 05 Apr 2018 

Updated by Antony Scott

Status In progress

8.1. Introduction

QGIS can use data in a number of database formats, both file-based (GeoPackage, SpatialLite), and
client/server (MSSQL, Oracle, DB2). However it is particularly tightly integrated with ,PostgreSQL/PostGIS
which is the focus of this module.

8.2. Connecting to PostGIS

PostGIS is a spatial extension to the PostgreSQL database. PostGIS supports spatial indexing, filtering,
processing and query capabilities, so if data is in a PostGIS database, you can choose to process and
manage it in the database itself, or through QGIS.

To use data from a PostGres database, first create a connection to it. You can do this from the Data
, but here we are going to use the .Source Manager Browser

In the panel, right-click on the  icon and click Browser PostGIS New connection

https://astuntech.atlassian.net/wiki/people/557058:c1a4281b-182c-4434-8cc5-337ef0a7929e?ref=confluence
http://postgis.net/
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2.  
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b.  

c.  

d.  

e.  

f.  

3.  

4.  

 

Populate the dialog using appropriate values as per the screenshot above:
: your name for the connectionName

: can be left blankService

: the server name or IP addressHost

: normally 5432Port

: the name of the database you are connecting toDatabase

: click the  button to add detailsAuthentication plus

Click  to see if the connection is working - note that the target PostGres instanceTest Connection
will normally need to be configured to accept connections from your IP address

If successful, click  to save the connectionOK

Connection options
Check Also list tables with no geometry to show non-spatial tables

If you have large tables and/or a large number of tables, speed up the processes of loading
the table list by checking  and Only show layers in the layer registries Use estimated table
metadata
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1.  

2.  

3.  

1.  

2.  

8.3. Load a PostGIS Layer 

With a connection defined, you can load layers from the PostGIS database:

In the , expand the  icon to view the content of the databaseBrowser PostGIS

Double-click on a layer (or drag and drop) to add it to the map

Add multiple layers using  or shift-click Ctrl-click

8.4. Load Vector Layers into PostGIS

Use the  to load vector layers into the PostGIS database.DB Manager

Go to Database > DB Manager > DB Manager
Browse to the target PostGIS database, and open the schema where you want to put the data
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2.  

3.  

4.  

Drag a layer from the  to the schemaBrowser

In the  dialog, usually defaults can be left in place - however the mainImport vector layer
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4.  

1.  

2.  

3.  

4.  

5.  

6.  

5.  

parameters are as follows:
Schema: change if required (note that if you want to put the data in a new schema, you will
need to create it first)

Table: enter a table name, or select from the dropdown to overwrite an existing table

Primary key: specify a field in the source data - otherwise  will be created by defaultid

Geometry column: will be  by default, but can be changedgeom

Source/target SRID: to use a CRS in the database which is different to the source, specify the
EPSG SRID in the  fieldTarget SRID

Create spatial index: check if spatial searches are going to be performed on the data

Click  to load the layer into the database OK
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9. QGIS Print Layouts

9. QGIS Print Layouts
9.1. Introduction

9.2. Create a Layout
Page Setup

9.3. Adding Layout Items
Add a Map

Add a Label

Add an Image

Add a Legend

Add a Scalebar

9.4. Output

9.5. Managing Print
Layouts

Templates

An Astun Technology Training Module

Code QGIS-09

Title QGIS Print Layouts

Description Producing print-ready output using map
layouts

Required
Software

QGIS v 3.0 or later

Target Audience QGIS Desktop users

Updated 04 Apr 2018 

Updated by Antony Scott

Status In progress

9.1. Introduction

Print Layouts are a distinct program module within QGIS, used to create map layouts for printing or
publication.

Be aware that:

Print layouts are saved to the QGIS project file (.qgs), so are directly linked to the project

There can be many print layouts in a project

Layouts can contain one or more items including:
Maps

Attribute tables

Text

Images

Legends

Scale bars
Layouts can be saved as templates and reused in other projects

9.2. Create a Layout

To create a print layout:

Go to Project > New Print Layout

https://astuntech.atlassian.net/wiki/people/557058:c1a4281b-182c-4434-8cc5-337ef0a7929e?ref=confluence
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Choose a name for the layout

The layout window will open showing a blank page

Page Setup

Go to  to set paper size, orientation and margins. You can also use the settings in theLayout > Page Setup
 and  tabs in the right hand panel to create guides (visible lines) and grids (invisible lines) toLayout Guides

help with layout. Grids can be set to snap to help keep items aligned.

Use the  menu to turn guides, grids, and snapping on and off.View

9.3. Adding Layout Items

With the page setup in place, you can add items to the layout. You can add as many items as you need,
and you can have more than one of each item type - for example you may want to add a main map and an
overview map.

Below are instructions for adding and configuring each of the main layout items.

Add a Map

To add a map to the layout:

Set up the map in the main map window as you want it to appear in the output - it's a good idea to
edit layer names at this stage so that they appear correctly in the legend

Click the  button in the  Add Map Toolbox Toolbar
Drag a box over the page where you want the map to appear
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3.  

4.  The current view of the map from the main map window will appear

Change the Map

You can change the map in two ways:

move the frame in which the map appears, by clicking and dragging on the frame, or dragging the

corners: the map frame must be selected using the  button Select/Move item

leaving the frame in place, but change the scale or positioning of the content: click the Move item

 button first, then use the mouse or  tab to make changes content Item Properties

Map Properties

With the map frame selected, the  tab controls configuration of the map - the main optionsItem Properties
are listed below.

 sets the scale of the map to a value entered in the fieldMain Properties > Scale:

 freezes the layers in the map frame, even if the map is changed in the mainLayers > Lock layers:
map window - if this is unchecked, and changes are made to the main map, the Print Layout map will
be updated with the changes

: with the layers locked, you can also choose to lock styles, so that styleLayers > Lock styles
changes in the main map will not affect the Print Layout map

: add one or more grids or graticules, using the CRS of the projectGrids

: where there is more than one map in the layout, an overview can be used to show theOverviews
extent of one map in the other

: set properties for the map frameFrame

Multiple Maps

A single layout can contain multiple maps: for example an overview or inset map. Maps are created in turn,
use the  button to freeze each map as it is completed. Some items, for example scalebars,Lock layers
need to be set to reference the relevant map.

Where one map extent sits within the extent of another, it's useful to an add an extent indicator in the
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second map using the  settings.Overviews

Add a Label

Labels (as text boxes are known in QGIS) are used to add text to the map: for example a title, description,
or copyright statement.

Select the  tool from the toolbar on the menu Add label

Click on the layout to position the label - the  dialog will appearNew Item Properties

Amend the settings as required, and click  to add the labelOK
A default label with default text will be created

Adjust the label size and location as required

Use the Item properties tab to configure the label, including:
Text content

Font

Colour

Alignment

Margins
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It is common to use multiple text boxes to include map metadata such as date of creation, contact details,
description, copyright and so on.

Add an Image

Any file-based image can be added to the Print Layout - for example a logo, a photograph, or any other
image relevant to the map.  You can also use this tool to add a north arrow to the map.

Click the  tool from the toolbar Add Image

Click on the layout to position the label - the  dialog will appearNew Item Properties

In the  tab, browse to an image, or look in  for SVG imagesItem Properties Search directories
shipped with QGIS.

Select an image to load it into the image frame, and resize the box to fit the size of the image

Formatting and expressions
To include formatting in the text box, check , then write or paste HTML intoRender as HTML
the panel.

Use the  button to use functions and variables in the box, using valuesInsert an expression
from your data, or QGIS variables such as date and user.
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Use Image  if necessary rotation to rotate the image

Add a Legend

To add a legend to the print layout:

Click  on the toolbarAdd Legend

Click on the map to position the legend - the  dialog will appearNew Item Properties

Click  to generate the legend and add it to the mapOK

The legend will require some configuration to bring to publication standard - the initial legend is a first draft.

By default, the size of the legend box is driven by its contents, and will include  items in the layer list,all
whether turned on or off. To change the size:

Remove any items in the layer list which aren't needed, or use the Legend Items > Filter Legend by

 button to show only layers which appear on the map Map Content

In the  tab, adjust ,  and Item Properties Fonts Spacing Position and size

Uncheck  - this allows you to change the size of the box, though it won't resizeResize to fit content
the legend items themselves

Set a blank Title

To edit the legend items directly in the Print Layout, uncheck the  box -Legend Items > Auto update
this activates the buttons below the list of legend items, and allows you to delete, edit and change the
order of items. Note that once you have done this, changes in the main map won't be reflected here.

Add a Scalebar

Click  on the toolbar Add new Scale Bar

Click on the map to position the scalebar, and click  on OK New Item Properties
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3.  The scalebar will appear on the page

Use the  tab to customise the scalebar - the  settings include pre-configured styles,Item Properties Style
including a numberic scale representation (e.g. 1:500,000).

9.4. Output

Print Layouts can be output:

directly to a printer 

to an image (in most common image formats) 

to SVG (for example for embedding in a web page) 

to PDF (for distribution, or for importing to graphics tools) 

9.5. Managing Print Layouts

Print Layouts can be managed in the    , from the  menu in the main QGIS windowLayout manager Project

or the toolbar in a . Print Layout

Map reference
Use the  setting if there is more than one map on the page - make sure the scalebar is pointingMap
to the correct one.
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Use the dialog to:

Create new blank layouts: New from template > Empty layout > Create

 a layoutRename
 a layoutDuplicate

 a layoutRemove

View an existing project layouts: Select layout and click Show

Create a layout from a template: browse to template or click  oNew from template > Specific >  User
r Default > Show

Templates

Templates are used to save a Print Layout for reuse either by you or other users - for example for a
corporate layout.

To save a layout as a template:

Go to  and nLayout > Save as template avigate to an appropriate location, and save under a descriptive
filename - e.g. . The file format for templates is .qpt - as with QGIS projectastun_A3_landscape_2018.qpt
files, this is an XML file.

Template paths
In  in the main QGIS menu, you can set searchSettings > Options > Layouts > Layout Paths
locations for templates - this would typically be a shared drive where corporate templates and other
resources are stored.
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10. QGIS Essentials: Exercises
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10. QGIS Essentials: Exercises
10.1. Getting Started

10.1.1. Objective

10.1.2. Get started and tidy up

10.1.3. Open a project and
arrange layers

10.1.4. Manage plugins

10.2. Working with Vector Data
10.2.1. Objective

10.2.2. Add Layers

10.2.3. Attribute Tables

10.2.4. Add Non-spatial Tables
and Create a Join

10.3. Styling Maps
10.3.1. Objective

10.3.2. Styling the Map

10.3.3. Add Annotations

10.3.4. Loading a Style

10.3.5. Additional Tasks

10.4. Selecting and Querying
10.4.1. Identify Features

10.4.2. Manual Selection

10.4.3. Selection using an
Expression

10.4.4. Field Calculator

10.4.5. Spatial Queries

10.4.6. Filter Layers

10.5. Loading Raster Data
10.5.1. Load individual rasters

10.5.2. Create a Virtual Raster

10.5.3. Load WMS layers

10.6. Data Creation and Editing
10.6.1. Create features

10.6.2. Edit features

10.6.3. Snapping and tracing

10.7. GeoProcessing for Analysis
10.7.1. Buffer and select points
in polygon

10.7.2.  Create centroids and a
distance matrix

10.7.3. Create a hexagon grid
and a point count

10.8. Print Layouts

An Astun Technology QGIS Training Module

Code QGIS-EX01

Title QGIS Essentials - Exercises

Description A set of exercises to support the QGIS
Essentials course.

Required
Software

QGIS v 3.0 or later

Target
Audience

QGIS Desktop users

Updated 23 Aug 2018   

Updated by Antony Scott

Status Complete

These exercises are designed to give you hands-on experience of the main techniques covered in the
course notes and slides. Explore other features of QGIS, and don't hesitate to ask if you need help.

https://astuntech.atlassian.net/wiki/people/557058:c1a4281b-182c-4434-8cc5-337ef0a7929e?ref=confluence
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10.1. Getting Started

10.1.1. Objective

Get familiar with the QGIS interface, layer management, customisation and configuration, plugins.

10.1.2. Get started and tidy up

Start QGIS.

Arrange the toolbars and panels, switching off toolbars you don't need for now (keep , Attributes Dat
, , , )a Source Manager Label Map Project

Go to   and review the settings, making any changes which are helpfulSettings > Options > General
- ' e.g. icon sizes, paths, language

Go to   and change  to Settings > Options > CRS Default CRS for new projects British National
, and the  to Grid CRS for new layers Use project CRS

10.1.3. Open a project and arrange layers

Go to , and  ...Project > Open open the project file /QGIS Training/Es /Projects/essentialssentials 3
 and save with a new name - create a new folder under  for your_01_gettingstarted.qgs Projects

own work

The project will open with a set of point, line and polygon layers

Rearrange the layers so that they are ordered in a way that they are all visible in the map

Create a group using the  button in the  panel , and put some of the layers in itAdd Group Layers

Go to  and give the project a titleProject >  > GeneralProperties

Right-click > Rename to make layer names more readable

Zoom to a scale where the layers are all readable

10.1.4. Manage plugins

Go to Plugins > Manage and Install Plugins

In the  tab, check Settings Show also experimental plugins

In the  tab, browse the plugins, and install All QuickMapServices

Load this plugin (it should now be in the Web menu), for example by adding the  layer StandardOSM

Install any other plugins which look useful



Commercial in Confidence 103 of 154 Copyright 2018 Astun Technology Ltd. All rights reserved.

1.  

2.  
1.  

2.  

3.  

3.  
1.  

2.  

10.2. Working with Vector Data

10.2.1. Objective

Load vector layers from various sources, create a table join with some non-spatial data.

10.2.2. Add Layers

Open the project from the previous exercise

Using the , add file-based dataData Source Manager :
Shapefile:  add wind_turbines_point.shp

MapInfo: add aonb_wales.mif

CSV: add  - note that this data is in WGS84playgroundsdata.csv
Add PostGreSQL data

Create a connection to the database:  > PostgreSQL > NewData Source Manager
Complete the connection details as below, using the Basic tab under authentication - note the
user credentials are pgis/pgis

Data location
All vector data is in  You may find it helps to use the...\QGIS Training\Essentials 3\Data\vector. 
file filter to look for only files of a certain type.
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Click Test Connection to make sure you can connect to the database - if successful, you will
see a confirmation message

Click , then  to open the connectionOK Connect
Browse to  and click Add, then Closeboundaryline > county_region

Add WFS data
Create a WFS connection   > WFS > NewData Source Manager
Complete the credentials as below (you may find it easier to search for the link on http://data.g

)ov.uk

http://data.gov.uk
http://data.gov.uk
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Click  then OK Connect

Click on the  to load, then  and layer you want Add Close

10.2.3. Attribute Tables

Open the attribute tables for some of the layers, and see how the data in the attribute tables relates
to the features on the map

Select an item in the attribute table by clicking on the row number - it will also be selected on the map

Click on the column headers to sort the table using that column

10.2.4. Add Non-spatial Tables and Create a Join

Go to Data Source Manager > Delimited Text

Browse to and load itIndex_of_Multiple_Deprivation_December_2015_Lookup_in_England.csv 
- you will need to to set the Geometry Definition  No geometry

Go to Data Source Manager > GeoPackage > New

Select LLSOA_Dec_2011_England_Wales.gpkg

Click , then select the table and Connect Add

Open the attribute tables for both Index_of_Multiple_Deprivation_December_2015_Lookup_in_E
 and  - notice that  in the former has angland LLSOA_Dec_2011_England_Wales  LSOA11CD

one-to-one relationship to  in the latterlsoa11cd
Follow the course notes to create a join between these two layers

Check the attributes of  to ensure the data has been joinedLLSOA_Dec_2011_England_Wales
correctly
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9.  Save the project
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10.3. Styling Maps

10.3.1. Objective

Add styling to the data you have been working with, replacing the QGIS default styling, and add some
annotations and labels.

Use the project you created in the last exercise, or if you don't have it, open anessentials_03_styling.qgs 
d save it with a new name.

10.3.2. Styling the Map

Create a  style for the  layer- use and amend one of the QGIS styles, orSingle symbol canal_crt
create your own from scratch

Create a   style for the   layer, using a  or  markerSingle symbol wind_turbines_point SVG Font

Create a  for , with a suitable fill - use transparency or hatching toCategorized style aonb_wales
make the layers underneath visible

Create symbols and name labels for the  layerrailway_naptan

Create a  for the  layer, using the  fieldGraduated style LLSOA_Dec2011_England_wales IMD15

10.3.3. Add Annotations

Add two or three text annotations to your map, indicating some points of interest from the OS OpenData
layer, with appropriate text. Edit the formatting, and choose a different symbol for each annotation.

10.3.4. Loading a Style

This section covers the use of a ready-made style - for this you are going to use OS MasterMap, and load a
saved style from a qml file.

Load the osmm_topo_area shapefile

Zoom to extents, noting the sample covers the city of Exeter

Load the style for MasterMap osmmstyle.qml

Have a look at the style, and how it is constructed

10.3.5. Additional Tasks

Apply a  style to , using the  field for exampleCategorized wind_turbines_point STATUS

Look at some of the fill styles for polygons under  layer type - for example , Symbol Centroid fill Sha
peburst fill
For a line or point, create a symbol with multiple components
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10.4. Selecting and Querying

In this exercise, you will work on selecting features, and writing and running queries to filter layers.

You can work with the same project as you were using for the previous exercise, or load a fresh version of
it from  and save it under a new name in your  folder.essentials_03_styling.qgs Documents

10.4.1. Identify Features

Use the ool to look at attribute values on some of your layers Identify Features t

Have a look at the  section, and use the  option to see a Derived Auto open form forms dialog

10.4.2. Manual Selection

Use the selection tools to create some manual selections on the map, and compare the results in the
attribute table for the layer

Make manual selections in the attribute table, and use the  and  tools to viewZoom map Pan map
them in the map

10.4.3. Selection using an Expression

In the attribute table for , select the 100 LLSOAs with theLLSOA_Dec_2011_England_Wales
highest Index of Multiple Deprivation - note that the   field is a ranking, so the lowest numberIMD15
represents the highest IMD 

Save the selection as a new GeoPackage file in your  folderDocuments
Using the new layer of top 100 LLSOAs, select those where the area is less than 100,000 hectares

Select all the LLSOAs in Tower Hamlets, using  (for a case-insensitive search) and the  wildcILIKE %
ard character 

10.4.4. Field Calculator

Create a new field which contains the name without the code at the end - i.e. omitting the last five
characters

You may want to do this in two steps - either by creating two columns, or by nesting the operators:
Using the  operator  to get the length of each nameString length 

Create a is five characters less than thenew field of datatype , with a length which string
original, using the  operatorleft

10.4.5. Spatial Queries

In , use  on the  toolbar toLLSOA_Dec_2011_England_Wales Select Features by Value Attributes
select LLSOAs in Tower Hamlets (you can use Starts with from the   dropdown on theExclude field

)right

Use  in the  to find all railway stations which fall within theseSelect by location Processing Toolbox
LLSOAs

Forms
Note that this dialog will only appear if you have selected a single feature - you may need to
zoom in to do this.
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Use  to add the attributes of the containing LLSOA features to each ofJoin attributes by location
the the railway stations you have found in Tower Hamlets

10.4.6. Filter Layers

Use one of the queries you have already created - or create a new one - and apply to one of the
layers on the map

Apply the same query as an attribute table filter
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10.5. Loading Raster Data

This exercise shows you how to add raster background mapping layers, and to add a set of raster images
from a folder.

10.5.1. Load individual rasters

Create a new project file and save it in your  folderDocuments

Click , then Open Data Source Manager Raster

Browse to and  in  (use Ctrl-click to select multiple files)open the .tiff files Data/raster/1250K

, and put these images in itCreate a group

10.5.2. Create a Virtual Raster

Go to Raster > Miscellaneous > Build Virtual Raster

Select the files you want to include in the raster - use the files in Data/raster/VMD

Uncheck , Place each input file into a separate band and set a location for the output file

Click Run in Background to create the virtual raster and load it into the map - this will take several
minutes to complete

Set scale dependencies on the raster layers you now have loaded, so they appear at appropriate
scales

10.5.3. Load WMS layers

Go to   (or another site with WMS data sources if you prefer)http://data.gov.uk

Search the site for a WMS layer, and copy the link

Use the  to create the connection, and load layers from the site Data Source Manager

Virtual Raster
Note that this exercise takes several minutes to run in the AppStream environment - you will need to
wait for the processing to complete.

http://data.gov.uk
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10.6. Data Creation and Editing

This exercise covers creating and editing vector data, both in the map and in the attribute table.

10.6.1. Create features

Create a new GeoPackage layer in your  folder. Ensure that it is a polygon type, and hasDocuments
the following attributes:

name (text)

date (date)

reference (integer).

Specify the CRS as EPSG:27700
Create two or three new features in the layer, populating the attributes when prompted

When this is done, open the attribute table for the layer, and make further edits

10.6.2. Edit features

Open one of the layers you have been using, and amend the geometry of some of the existing
features, including lines, points and polygons

Use  to create new featuresCopy/Paste
Use the tools in the  toolbar to amend the geometry, includingAdvanced Digitizing

Split Features: craw a line across a feature to split it into two

Extend Features: draw an extension to a feature

Rotate Features: turn features round

Add part: add a new part to a multipart features

10.6.3. Snapping and tracing

Turn on the , and activate snappingSnapping Toolbar

Use the second button to go to , and set snapping to one of the layers - forSnapping Options
example  - with a tolerance of 50 metresrailways_naptan
Create a new line layer, and draw lines between railway stations to create a representational map of
part of the railway network, with vertices snapping to existing stations

Turn on  in the toolbar, and create a new AONB, which adjoins one of the existingEnable Tracing
AONBs, using tracing to make part of the boundary coincide

Tun on  in the toolbar, and adjust one of the common boundaries in aEnable Topological Editing
polygon layer, for example in LLSOA_Dec_2011_England_Wales
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10.7. GeoProcessing for Analysis

This exercise uses  to address some spatially-relateda combination of geo processing techniques
questions.

10.7.1. Buffer and select points in polygon

Create a new project and save it

Open the  and  layersnat_parks_england railway_naptan
Create a 10km buffer round the Lake District National park

Use  to find out how many railway stations are within 10km of the parkSelect by location

10.7.2.  Create centroids and a distance matrix

Open the  layer county_region_england

Use the  process to create a layer of the centroid of each countyCentroids

Use a  to find the three nearest railway stations to each centroid Distance Matrix

10.7.3. Create a hexagon grid and a point count

This stage visualises the density of railway stations across Great Britain.

Using the   tool, create a hexagon grid to cover the extent of the railway stations layerCreate grid
Zoom to the extents of the railway stations layer

Create a 30km hex grid for the extents of the layer, with settings something like:



Commercial in Confidence 113 of 154 Copyright 2018 Astun Technology Ltd. All rights reserved.

1.  

b.  

b.  

c.  

Use  with the grid as the polygon layer, and the railway stations as the Count points in polygon poin
ts layer

Create a style to visualise the results, using the field name specified in  in theCount field name
previous step (e.g. NUMPOINTS)



Commercial in Confidence 114 of 154 Copyright 2018 Astun Technology Ltd. All rights reserved.

10.8. Print Layouts

Use a project file from an exercise of your choice to create a Print Composer page. Use as many of the
tools and features as possible, as covered in the course notes, including:

: including editing the legend in the Print ComposerLegend

: including adjusting settingsScalebar

: of your choiceImage

: try using some HTML, and/or an expressionText

: change the settings to include a subset of the attributesTable

: with an extent indicator on the main map, formatted as a red outlineOverview map

When you have loaded all the elements onto the page, if you have time, fine-tune the layout to improve the
quality and usability for the reader.

When you have finished, save the result as a PDF and also as a PNG image into a suitable location, with
your name as part of the filename - we will review some of the final maps together.
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1. QGIS Atlas

1. QGIS Atlas
1.1. Introduction

1.2. Setting up the Atlas

1.3. Review the results

1.4. Add further elements

1.5. Use a hidden layer

1.6. Set styling to highlight the layer in
focus

An Astun Technology QGIS Training Module

Code QGIS-A01

Title QGIS Atlas

Description Using Atlas to create data-driven
maps

Required
Software

QGIS v 3.2 or later

Target
Audience

QGIS Desktop users

Updated 23 May 2019 

Updated by Antony Scott

Status Complete

1.1. Introduction

Atlas is a component of Print Layouts which allows multiple output pages to be automatically generated
from a single Layout, driven by an attribute of the data, with a page for each feature. This is commonly used
to produce, for example, a single map for each feature in an administrative boundary layer, for example
wards or counties.

Various settings are available, and as well as the map itself being dynamic, other items in the Layout such
as titles can be dynamically generated, with attribute values drawn from the current feature.

1.2. Setting up the Atlas

Open the QGIS project ...\Advanced\Projects3\atlasgeneration

There are three layers

april2011_street (individual crime incidents)

surrey_neighbourhoods_crime_atlas
OS Opendata WMS

The task is to create an atlas with one page for each neighbourhood, displaying all the data available.

To do this:

Go to Project > New Print Layout
Enter an appropriate name, e.g. Epsom neighbourhoods

Add a map, legend, scalebar and label

https://astuntech.atlassian.net/wiki/people/557058:c1a4281b-182c-4434-8cc5-337ef0a7929e?ref=confluence
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4.  

5.  

1.  

Go to , and complete according to the screenshot below: Atlas > Atlas Settings

Select the map, navigate to the  tab and complete as follows:Item properties

1.3. Review the results

Use the Atlas toolbar controls to review the maps - first click on  (the right-hand button on thePreview Atlas
Atlas toolbar) to activate the tools. 

Use the left and right arrows to scroll through the Atlas pages.

1.4. Add further elements

In the label box, use  to add a dynamic title to the map pages - so that theInsert an expression
result is something like:
Crime Incidents for Neighbourhood EPWE: map 3 of 10
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1.  

2.  

3.  

4.  

1.  

2.  

3.  

Note that you will need to find the correct expression to produce this result - look under Fields and 
Values and  in the dialogue.Variables  Expression Builder 

Add any other features to the map you think might be useful, and any other fields or variables.

Review the updated output pages in the preview.

Change the scale settings for the map, and review the results.

When you have created an atlas which is ready to produce, export the results.

Go to the  menu and export as PDFAtlas

Choose folder ...\Advanced\Atlas\output
On completion, open the PDF output and review, then revise and regenerate the output if necessary.

The output can be produced as a single PDF multi-page file, or as a series of single PDFs, one for each
feature. To produce single pages, ensure is unchecked in the  tab,Single file export where possible  Atlas
and edit the  value using the expression builder, to use an attribute value fromOutput filename expression
the feature in the filename.
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1.  

2.  

3.  

4.  

5.  

6.  

7.  

8.  

1.5. Use a hidden layer

You can use a coverage layer which is not visible in the map to drive the Atlas - check the Hidden
 box to do this.coverage layer

This could be a grid layer for example, or a layer with polygons for specific areas of interest. If you have
time, try using this approach, creating an appropriate layer.

1.6. Set styling to highlight the layer in focus

You may want your styling to differentiate between the feature which is the focus of the map, and the other
features, so that it stands out. To do this, you will need to add a rule-based style for every layer which you
want to change.

In the  tab for the layer:Symbology

Select  from the style drop-down at the topRule-based

Click the  button at the bottom of the dialog to add a new rule+

Expand the  dialog so you can see all the controlsEdit Rule

Enter 'Feature in focus' for the , to remind you that this new rule will only apply to the currentLabel
Atlas feature

Open the expression builder dialog, and in the search box enter 'id'

Use the results to create the expression  - this will apply the style in the rule $id = @atlas_featureid
only to the current Atlas feature

Set the styling for this rule, and for the other default rule as you wish - for example you may want to
change colours and transparency

Preview the Atlas pages in the Print Layout to see the results

If you want to make the styling of features other than those in the coverage layer dynamic, you'll need to
use an expression which determines, for example whether they are inside the current feature:

within($geometry, @atlas_geometry)
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You may also want to use other Geometry functions such as , or intersects overlaps.
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3.  

4. QGIS Georeferencing

4. QGIS Georeferencing
4.1. Introduction

4.2. Open the project and load
the Georeferencer

4.3. Load the source data

4.4. Create GCPs

4.5. Run the Georeferencer

An Astun Technology QGIS Training Module

Code QGIS-A04

Title QGIS Georeferencing

Description Using the georeferencing tool to use
unreferenced raster images.

Required
Software

QGIS v 3.2 or later

Target
Audience

QGIS Desktop users

Pre-requisites

Updated 01 Aug 2018 

Updated by Ian Turton

Status Complete

4.1. Introduction

Georeferencing is used when raster data is not referenced to a CRS. The process adds coordinate
references to a raster image so that it can be used in QGIS alongside other layers.

4.2. Open the project and load the Georeferencer

Open project ...\Advanced/Projects/Georeferencing.qgz
The map shows an area of Exeter, including a MasterMap layer and the OS open data WMS. You
may want to load the style file for MasterMap from the earlier exercises.

Go to  (if you don't see this in the menu, go to the  andRaster > Georeferencer Plugin Manager
enable the  plugin).Georeferencer GDAL

You are going to use the Georeferencer tool to open a non spatiallly-referenced image of a map, and
reference it to the QGIS layers based on coordinates and common features across the maps.

4.3. Load the source data

Click the  button iOpen raster n the Georeferencer. 

Navigate to and open  (from ...\Advanced\Data\Raster\baedek_exeter_1900.jpg http://freepages.ge
)nealogy.rootsweb.ancestry.com/~genmaps/genfiles/COU_files/ENG/DEV/baedek_exeter_1900.htm

http://freepages.genealogy.rootsweb.ancestry.com/~genmaps/genfiles/COU_files/ENG/DEV/baedek_exeter_1900.htm
http://freepages.genealogy.rootsweb.ancestry.com/~genmaps/genfiles/COU_files/ENG/DEV/baedek_exeter_1900.htm
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1.  
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3.  

Go to , and add settings as in the screenshot below:Settings > Transformation Settings

Look at the image alongside the QGIS map to understand how it relates to the other layers. You will need
to identify features in common such as road junctions, or railway stations - you will need at least four of
these, well spread out across the map. These are called Ground Control Points (GCPs).

You will see that the graphic contains two maps, each at a different scale - if possible, you should
georeference both of these (create a copy of the original JPEG to create the second).

4.4. Create GCPs

Create your first control point by selecting the  tool Add point
Click on the map image on a feature you will be able to identify on the QGIS map - for example the
main railway station.

On the dialogue that appears, click  From map canvas
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3.  

4.  

5.  

6.  

7.  

1.  

2.  

3.  

4.  

Identify and click on the same feature in the QGIS map

Click  - a point will appear on the map, with a corresponding reference in the table below.OK
Complete this task at least a further three times at different locations on the map where features can
be identified, ensuring they are well distributed. This might take some time - use zoom controls to be
as accurate as possible.

Use the  tool if necessary to correct point locations, or to delete points and recreate.Move GCP point

4.5. Run the Georeferencer

When you are happy with the GCPs you have collected, click the  button Start georeferencing
Minimise the Georeferencer to see the results.

Your map should now be in the main QGIS map window, lined up with the MasterMap data.

If you are not happy with georeferencing, go back to the georeferencer and try again.

When you have completed this, repeat the exercise using the second map on the graphic, making a copy of
the original JPEG to use as your source.
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5. QGIS Raster Analysis

5. QGIS Raster Analysis
5.1. Introduction

5.2. Open Raster Data

5.3. Create a hill-shaded image

5.4. Aspect, Slope and Raster calculations
Create Aspect image

Create Slope image

Raster Calculations

5.5. 3D Viewing

An Astun Technology QGIS Training Module

Code QGIS-A05

Title QGIS Raster Analysis

Description Raster analysis

Required Software QGIS v 3.2 or later

Target Audience QGIS Desktop users

Updated 03 Sep 2018 

Updated by Antony Scott

Status Complete

5.1. Introduction

Raster data is a wide field of analysis, so in these exercises we will introduce some common techniques
and tools, and work with some specialist raster processing plugins. We are going to use some UK
Environment Agency LIDAR data as our example.

5.2. Open Raster Data

Open the project ...\Advanced\Projects\Rasteranalysis.qgz
Add the following raster image: 
...Advanced\Data\raster\EA_1m_\EA_1m_DTM\EA 1m DTM - LiDAR Derived (ASC Grid File).asc

Go to  and under the section set the values as follows ifLayer > Properties > Style Band rendering 
they aren't set already:

Set the  to Render type Singleband gray

Set  to   Contrast enhancement Stretch to MinMax

Set the  under  to Accuracy Load min / max values Actual (slower)

https://astuntech.atlassian.net/wiki/people/557058:c1a4281b-182c-4434-8cc5-337ef0a7929e?ref=confluence
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3.  

3.  

4.  Click .OK

The result will look like the image below - a LIDAR image of an area of land at the mouth of the
Congresbury Yeo river in Somerset, UK.
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1.  

2.  
a.  

b.  

c.  

d.  

e.  
c.  

1.  

2.  

5.3. Create a hill-shaded image

To give a more meaningful representation of relief, we are going to add some hill shading to the image.

Go to Raster > Analysis > Hillshade
In the dialogue, make sure the settings are as follows:

Input layer: EA 1m DTM – LiDAR etc…
Band number: Bnad 1

Output layer: ...\Data\Raster\Output\hillshade300.tif

Z factor: 1

Check Open output file after running algorithm
Click Run in background

The data will be processed, and the new image added to the map. The image will be in standard greyscale,
and you should be able to visually identify features.

To improve the appearance, use a psuedo-colour ramp.

Go to  for the new hillshade layer and set the  to Symbology Render type Singleband pseudocolor

Under , choose an appropriate color map from those available in the drop down list (eg Color ramp Pi
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2.  

3.  

4.  

5.  

), then click YG Apply

For a more terrain-like colour scheme, scroll to the bottom of the color ramp list and choose New
, then in the dropdown select  which includes a variety of categorised colourcolor ramp... cpt-city

ramps

Select a colour ramp and click OK

The result should be similar to the following:
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5.  

6.  

7.  

1.  

2.  
a.  

b.  
c.  

Click OK.

Review the results in the map window.

Create an additional hill-shaded image, changing  to 210 degrees and call the file .Azimuth hillshade210
Examine the differences between the two images you have created to see how changing light source
affects the clarity of the different features on images.

5.4. Aspect, Slope and Raster calculations

The next exercise includes several parts, using different tools to create a map of areas identified for
development.

You need to identify areas for development that meet some specific criteria:

The area needs to have a south-facing aspect

The area should have a slope of less than 3 degrees.

Create Aspect image

First determine the aspect.

Select    > Raster Analysis > Aspect

Enter details as below:
Elevation layer: EA 1m DTM – LiDAR etc…

Output layer: \\Raster\Output\aspect.tiff...\Advanced\Data\raster
Click Run in Background

The image will be created and loaded with a singleband grey, looking similar to this.
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1.  

2.  
a.  

b.  

 

Examine the image, and change the Style settings to experiment with different visualisations. Using the
Identify tool, click locations in the image to identify the pixel values - note that each value is in degrees
between 0 to 360, indicating the aspect of the slope.

For more information about the range of pixel values, go to the Properties for the layer and click the
Histogram tab.

Leave the aspect layer for now - you will make use of it after the next section.

Create Slope image

To determine the degree of slope across the terrain:

Select Raster > Analysis > Slope
Enter details as below:

Elevation layer: EA 1m DTM – LiDAR etc…

Output layer: C:\Users\PhotonUser\My Files\Home Folder\Documents\QGIS
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b.  

c.  

1.  

Training\Data\raster\Data\Raster\Output\slope.tiff
Click Run in Background

The image will be created and loaded as singleband grey, looking similar to the following:

Examine the image, and change the Style settings to experiment with different visualisations. Using the Ide
ote each value is in degrees indicatingntify tool, click locations in the image to identify the pixel values - n

the steepness of the slope.

As with the previous image, check the histogram to get an understanding of the type of terrain in the area.

Raster Calculations

Having created the images for slope and aspect, you are going to perform three calculations using the
raster calculator which will identify pixel values and hence areas that meet your selection criteria.

The first will identity all areas where the aspect is south facing - for this you are looking for aspects that
range from 135 degrees to 225 degrees.
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7.  

1.  

2.  

Go to Raster > Raster calculator

Create the expression below using your own aspect layer names in the expression box

Enter an   name such as Output layer aspect_south.tif

Check Add result to project

Click OK
The image should be created and loaded as a grey rectangle.

Examine the image on the map. The values used are a Boolean dataset, with 1 representing areas
that meet your criteria.

Repeat the same steps for slope, using the following formula with your layer name, to determine
slope less than three degrees, saving the layer as slope_3.tif:
slope@1 < 3

You can now use the 1 and 0 values in both layers to calculate the area that meets both criteria.

Open the raster calculator, and this time use the formula (with your layer names) as follows:
aspect_south@1 = 1 AND slope3@1 = 1

Set Color ramp settings on the resulting layer (if necessary) and view the results.

5.5. 3D Viewing

We can visualize the data in 3D using the QGIS plugin Qgis2threejs plugin.

Install the  pluginQgis2threejs 
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6.  

1.  

2.  

1.  

Turn off all layers apart from the LIDAR data and the OS Premium WMS layer, and ensure that the
OS Premium layer is above the LIDAR in the layer list.

Go to Web > Qqis2threejs > Qgis2threejs Exporter

In the  section, turn on the LIDAR layer as the DEM LayerDEM

In , set  to 3File > World Settings Vertical exaggeration
In the Preview panel, you will see a zoomable 3D image

The scene can be exported to a website, although you will probably only be able to view the site from the
file system in Firefox.

Go to , then click File > Export to Web Export
If Firefox is not your default browser, copy and paste the URL and view it in Firefox, or set the
browser path to Firefox in File > Exporter Settings

You can include vector layers in the view as well.

Add a point vector layer to the project, select the layer in the Exporter and  tRight-click > Properties
o set height and style options.
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6. QGIS Graphical Modeler

6. QGIS Graphical Modeler
6.1. Introduction

6.2. Summary

6.3. Create a point layer from CSV

6.4. Convert the Price field to an
integer

6.5. Add a vector grid to use for
analysis

6.6. Join the house price points to
the grid polygons and summarise

6.7. Results

6.8. Add some styling

6.9. Working with the model

An Astun Technology QGIS Training Module

Code QGIS-A06

Title QGIS Graphical Modeler

Description Automating processing tasks using the
Processing Toolbox and Graphical Modeler

Required
Software

QGIS v 3.2 or later

Target
Audience

QGIS Desktop advanced users

Updated 04 Sep 2018 

Updated
by

Antony Scott

Status Complete

6.1. Introduction

This module covers the  , which allows you to build and save process models containingGraphical Modeler
one or more steps using a graphical interface.

Once a model has been built, it can be:

Run from within QGIS, with different inputs

Run as a standalone process using Python, for example from a batch file

Made available as a shared resources

The Modeler can make use of any processes in the , so it's a useful tool forProcessing Toolbox
automating most things that QGIS can do.

6.2. Summary

The module shows you how to build a short workflow, so that it can be stored, repeated and shared.

The aim of the example is to take house price data from Bath in the UK, and represent it as a
choropleth-styled map based on a grid.

The steps in the process are:

Load CSV file of house sale prices

Process the data to convert the  field from a string to an integerPrice
Create a vector grid

https://astuntech.atlassian.net/wiki/people/557058:c1a4281b-182c-4434-8cc5-337ef0a7929e?ref=confluence
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4.  
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2.  

3.  
a.  

4.  
a.  

b.  

c.  

Join the house price data with a grid layer, summarising the individual price data as part of the
process

Once these steps have been completed, you should have both a point layer of all house sales, and
summary house price data for each cell in a grid overlay.

To get started: 

Open a new project in QGIS

In the Data Source Manager, us the   option to load Delimited Text Advanced/Data/Vector/House_P
, setting the  to rice_Paid_Bath_Land_Registry.csv Geometry definition No geometry

Ensure the project CRS is set to EPSG: 27700

Save the project in a suitable location (e.g. )/Advanced/Projects/graphicalmodeler.qgz

6.3. Create a point layer from CSV

We'll now create a model to do the processing.

Go to Processing > Graphical Modeler
In Model Properties, complete the Name and Group fields with appropriate names (e.g.  House prices
and QGIS Training)

Create a placeholder for the the input layer
In the   tab, double-click on , and in enter   Inputs Vector Feature Parameter Name  CSV Prices
and click OK

Select a processing tool
In the  tab, search for points layerAlgorithms

Select the QGIS algorithm Create points layer from table
Complete the dialogue as shown below to create a points layer from the CSV
Note that because at this point you haven't specified an input file, only a placeholder, you will



Commercial in Confidence 134 of 154 Copyright 2018 Astun Technology Ltd. All rights reserved.

4.  

c.  

5.  

need to type in the values for X field and Y field rather than use the drop-downs. You should
also set the CRS to EPSG:27700.

Save the model to your Documents folder with an appropriate name (e.g. ) - you should houseprices
have something like this:
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6.  

7.  

8.  

9.  

Click the  button to show the dialogue below: Run

Check the settings, and click  to run the modelRun
Make sure that whenever you run the model, the original input file (House_Price_Paid_Bath) is
selected under CSV Prices

You should see a new layer on the map,  - look at the layer to see that it'sPoints with geometry  
correct.

Right-click > Remove on the new layer to clean up

6.4. Convert the Price field to an integer
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3.  

4.  

1.  

2.  

In this step, you will need to convert the  field to an integer in order to work with it - it's currently aPrice
string, and has a '£' sign at the beginning. We'll use the field calculator to do this, but running it from the Gr

 instead of the usual dialogue.aphical Modeler

In the  tab, search for Algorithms field calculator
Double click on Field Calculator, and complete the dialogue as the screenshot below
The formula you need to enter is below - it uses replace() to remove the £ sign from the string, and
to_int() to convert the string to an integer

to_int(replace(Price,'£',''))

Note that the characters before the two last brackets are two single quotes, not a double
quote.

Click , then save and run the modelOK

You should now have an additional point layer, with a new field  - check that this is correct.price_int

6.5. Add a vector grid to use for analysis

We'll now overlay a vector grid which we can use to analyse the point vector data.

In the  tab, search for grid and select Algorithms Create grid
Complete the dialogue as shown below - this will create a grid of 1km squares which covers the
extent of the point layer
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2.  
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Save and re-run the model

You should now have a 1km polygon hex grid overlaying the point layers

Remove all the layers except the original CSV, and save the model

6.6. Join the house price points to the grid polygons and summarise

In the  tab, search for Algorithms join

Double click on Join attributes by location (summary)
Complete the dialogue as below
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3.  

4.  
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Save and run the model

You should see a new grid layer, with the a mean attribute for the house prices in each grid unit

6.7. Results

By this time, you should have a model which looks like this:
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and your main QGIS interface should look something like this:
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1.  

2.  

6.8. Add some styling

We've now got a process which creates a hex grid containing summary statistics on house prices for each
hexagon square, so to make it useful we can add some styling.

Add a WMS layer of background mapping - for example ADS OS Premium

Right click on the new  layer and go to , then select ahouse_prices_grid Properties > Style  Gradua
 style and use the  column, with  set to . ted price_int_mean Mode  Quantile (Equal Count)
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2.  

3.  With the style applied, you should see a map something like this
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3.  

4.  Once you have created the styling, save the project

6.9. Working with the model

Once the model has been created, it can be:

run manually

shared with other users

run as a standalone programme using Python, allowing it to be scheduled
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7. QGIS Time Manager

7. QGIS Time
Manager

7.1. Introduction

7.2. Steps

An Astun Technology QGIS Training Module

Code QGIS-A07

Title QGIS Time Manager

Description Using the QGIS Time Manager plugin to create
animations

Required
Software

QGIS v 3.2 or later

Target Audience QGIS Desktop users

Updated 04 Sep 2018 

Updated by Antony Scott

Status Complete

7.1. Introduction

This module describes how to create animations using the Time Manager plugin, for viewing in QGIS or to
create a video.

7.2. Steps

Install the  pluginTimeManager

Go to , and load the source dataOpen Data Source Manager > Delimited Text  ../Advanced/Data/V
 - you will needector/Migratory connectivity of purple martins (data from Fraser et al. 2016).csv

to use the  and  fields as  and , and  as the CRSlocation-long location-lat x y EPSG:4326 - WGS 84

In the  dialogue, click Time Manager Settings > Add Layer
Complete the settings as in the screenshot below

https://astuntech.atlassian.net/wiki/people/557058:c1a4281b-182c-4434-8cc5-337ef0a7929e?ref=confluence
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If you find that the ID attribute field is greyed out, enter the value tag-local-identifier (which identifies
the individual bird) manually in the main Time Manger dialog after clicking OK, in the ID column for
the layer

Click  and  again to return to the main QGIS screenOK OK
In the Time Manager dialogue, set the appropriate time for the gap between each frame - for this data
we will start with 1 day

If it is not already activated (green), click the button to activate the animation 

Your screen should now look something like this

a.  

b.  

Note that:

The date in the  selection  be in one of the formats listed in the TimeStart time must
Manager help on the previous dialogue (though it need not be in date format in QGIS)

Interpolation will fill in any gaps in the data - i.e. dates for which no data exists. You will
need to complete the ID attribute selection to indicate the item or object of focus to
which dates need to be added - in this case individual tagged birds
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9.  

10.  Click the play button to run the animation   - this button is sometimes not visible, but it is to the
left of the timestamp as in the screenshot above, so if you click there, the animation should run.

Once the animation is working, you can go back and change the settings to see how this affects the results.
Note that you can also style the source layers (though you will have to remove them from the Time
Manager settings first), and you may want to add a WMS background layer to show some context.

When you are happy with the animation, you can use the Export Video button to export the frame into a
folder. In Windows, you will then need to use a video editor to produce a video.

Source data
For the animation to work correctly, the source data must be fully normalised - i.e. there must be
row in the attribute table for each item to be animated for each time stamp. You may need to
prepare the data in an external programme such as a spreadsheet in order for this to be the case.
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8. QGIS Point Cluster Styling

8. QGIS Point Cluster Styling
8.1. Introduction

8.2. Load data

8.3. Set initial styling

8.4. Add point clustering

8.5. Add data dependency to symbol
size

8.6. Using geometry generators

An Astun Technology QGIS Training Module

Code QGIS-A08

Title QGIS Point Cluster Styling

Description Using point cluster styling in
QGIS

Required
Software

QGIS v 3.4 or later

Target Audience QGIS Desktop users

Updated 11 Sep 2019 

Updated by Antony Scott

Status In development

8.1. Introduction

This module shows how densely populated point data can be styled using clustering, with OpenStreetMap
data being used as an example.

8.2. Load data

Install the  plugin - this will allow us to download OpenStreetMap dataQuickOSM

Open a  base map (for example OSM Standard) and navigate to a large city inQuickMapServices
the UK

Go to  to open the  dialog, from which you can run Vector > QuickOSM > QuickOSM QuickOSM
queries to download OSM data

Complete the dialog as per the screenshot below, and click Run query

https://astuntech.atlassian.net/wiki/people/557058:c1a4281b-182c-4434-8cc5-337ef0a7929e?ref=confluence
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New layers will be added to the map, showing data for pubs in the area you have selected

Depending on the area, you may get polygon and line data as well as points - turn these off, leaving
just the points

8.3. Set initial styling

Add a  to the data,Simple style  using an appropriate SVG symbol

Adjust the settings on the symbol from the default, and experiment with the  at theDraw effects
bottom of the dialog to create a reasonable-looking symbol
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You should now have a representation of pubs in the city, though some of the points will probably
overlap - we are going to address this using point clustering

8.4. Add point clustering

Go back to , and choose  as the type, then Symbology Point cluster Apply
You will see that where pubs are within a certain distance of each other, the points are replaced by a
point cluster marker, showing the number of pubs represented by the marker

This is useful, but it would be better to use our custom symbol rather than the default red symbol

Click on the  button, and change the  to an , using theCluster symbol Simple marker SVG marker
same settings as for your original marker

You may need to change the size of the marker or the font to ensure that the numbers are visible

Your map should now look something like this
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8.5. Add data dependency to symbol size

The map might be more useful if we could make the size of the symbols dependent on the number of pubs
in the cluster.

In the  dialog, click on the , and notice that the symbol to the right of theCluster symbol Font marker
font characters is highlighted in yellow - this means that a data dependency has been set

Click on the symbol - it shows that the   function is being used to generate a number to@cluster_size
show in the symbol
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We can use this function to drive the symbol size - click on the SVG marker

Click on the , and select  from the menuData defined override button   to the right of Width Edit
(note that you may have to resize the window to see this button)

In the  dialog, type    Expression @cluster_size
When you apply the style, the marker size will vary depending on the size of the cluster

Adjust the size of the marker and the font, using a multiplier on the   function if@cluster_size
necessary, until you have a style you are happy with



Commercial in Confidence 151 of 154 Copyright 2018 Astun Technology Ltd. All rights reserved.

1.  

2.  

3.  

4.  

5.  

8.6. Using geometry generators

There are QGIS styles which support geometry transformations, such as buffering and centroids, on the fly.
We can use these, for example, to show as points the pubs which are represented as polygons.

Turn on the polygon pubs layer

In , select  and click onSymbology Single symbol  Simple fill

Change the  to Symbol layer type Geometry generator

Click on the expression icon on the right, and  - you can then use this to create ansearch for centroid
expression  to show the polygons as centroidscentroid($geometry)

Note that you will also need to set the correct output  (in this case Point/MultiPoint),Geometry type
so your dialog should now look like this
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Add appropriate styling and apply

Experiment with other geometry generators - for example buffers to show the areas within a certain
distance of a pub
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11. QGIS Plugins

11. QGIS Plugins An Astun Technology QGIS Training Module

Code QGIS-P01

Title QGIS Plugins

Description A review of selected plugins.

Required Software QGIS v 3.0 or later

Target Audience QGIS Desktop users

Updated 23 Aug 2018 

Updated by Antony Scott

Status Complete

Name Description | Ease of Use (1 =
easy, 5 = hard) 

  Comments

autoSaver Saves project and data files at a
specified interval.

1 QGIS has no native functionality which
does this.

Data Plotly Add a linked graph to your map or
print layout.

2

Discovery Provides search / gazetteer
functionality in QGIS using
PostGIS-based data

1 Works on PostGIS data only.

go2streetview Adds a drag and drop cursor which
opens Google StreetView.

1 Requires Google Maps API key.

Memory Layer
Saver 

Saves any current scratch layers
alongside the project file, so they are
available to the project next time it is
opened.

1 Data saved as .mldata.

MetaSearch
Catalog Client

Interacts with metadata catalogue
services, supporting the OGC
Catalogue Service for the Web
(CSW) standard, and allowing CSW
catalogues to be accessed from
within QGIS.

2
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mmqgis Vector layer manipulation tools. 1 Duplicates much of existing QGIS
functionality, but sometimes provides
useful additions/alternatives.

OS Translator II Loads GML-based datasets into
PostGIS and performs
post-processing tasks.

2 Specifically developed for Ordnance
Survey GML data.

Qgis2threejs Generates a 3D interactive model of
raster DEM data, including in-browser
controls. Also allows 3D
representation of vector data.

3 Needs configuration, but models can
be produced and regenerated very
quickly.

qgis2web Allows generation of an OpenLayers
or Leaflet web map from the current
project.

1 Produces output set which can be
published directly to the web or loaded
in a local browser.

QuickMapServices Provides a menu and search for 
WMS services for background
mapping, including for example
Google, Bing and OpenStreetMap.

1

QuickOSM GUI query for OpenStreetMap data
selection and dowload.

1

QuickWKT Allows you to paste in data in WKT 
format (e.g. from PostGIS or other
programs) and see it on the map

2

Spreadsheet
Layers

Allows a spreadsheet layer to be
loaded with datatype selection, using
coordinates to set geometry. 

1 Allows point data with coordinates to
be loaded as spatial layer without
loading to CSV.

TimeManager Creates a video based on data with a
time component.

4 A fair amount of config needed, and a
video-editing application may also be
required to produce the final outputs.

zoomtopaste Zoom to a set of coordinates pasted
from the clipboard.

1
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