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These exercises are designed to give you hands-on experience of the main techniques covered in the
course notes and slides. Explore other features of QGIS, and don't hesitate to ask if you need help.

10.1. Getting Started

10.1.1. Objective

Get familiar with the QGIS interface, layer management, customisation and configuration, plugins.

10.1.2. Get started and tidy up

Start QGIS.

Arrange the toolbars and panels, switching off toolbars you don't need for now (keep , Attributes Dat
, , , )a Source Manager Label Map Project

Go to   and review the settings, making any changes which are helpfulSettings > Options > General
- ' e.g. icon sizes, paths, language

Go to   and change  to Settings > Options > CRS Default CRS for new projects British National
, and the  to Grid CRS for new layers Use project CRS

10.1.3. Open a project and arrange layers

Go to , and  ...Project > Open open the project file /QGIS Training/Es /Projects/essentialssentials 3
 and save with a new name - create a new folder under  for your_01_gettingstarted.qgs Projects

own work

The project will open with a set of point, line and polygon layers

Rearrange the layers so that they are ordered in a way that they are all visible in the map

Create a group using the  button in the  panel , and put some of the layers in itAdd Group Layers

Go to  and give the project a titleProject >  > GeneralProperties
Right-click > Rename to make layer names more readable

Zoom to a scale where the layers are all readable

10.1.4. Manage plugins

Go to Plugins > Manage and Install Plugins

In the  tab, check Settings Show also experimental plugins

In the  tab, browse the plugins, and install All QuickMapServices

Load this plugin (it should now be in the Web menu), for example by adding the  layer StandardOSM

Install any other plugins which look useful
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10.2. Working with Vector Data

10.2.1. Objective

Load vector layers from various sources, create a table join with some non-spatial data.

10.2.2. Add Layers

Open the project from the previous exercise

Using the , add file-based dataData Source Manager :
Shapefile:  add wind_turbines_point.shp

MapInfo: add aonb_wales.mif

CSV: add  - note that this data is in WGS84playgroundsdata.csv
Add PostGreSQL data

Create a connection to the database:  > PostgreSQL > NewData Source Manager
Complete the connection details as below, using the Basic tab under authentication - note the
user credentials are pgis/pgis

Data location
All vector data is in  You may find it helps to use the...\QGIS Training\Essentials 3\Data\vector. 
file filter to look for only files of a certain type.
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Click Test Connection to make sure you can connect to the database - if successful, you will
see a confirmation message

Click , then  to open the connectionOK Connect
Browse to  and click Add, then Closeboundaryline > county_region

Add WFS data
Create a WFS connection   > WFS > NewData Source Manager
Complete the credentials as below (you may find it easier to search for the link on http://data.g

)ov.uk

http://data.gov.uk
http://data.gov.uk
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Click  then OK Connect

Click on the  to load, then  and layer you want Add Close

10.2.3. Attribute Tables

Open the attribute tables for some of the layers, and see how the data in the attribute tables relates
to the features on the map

Select an item in the attribute table by clicking on the row number - it will also be selected on the map

Click on the column headers to sort the table using that column

10.2.4. Add Non-spatial Tables and Create a Join

Go to Data Source Manager > Delimited Text

Browse to and load itIndex_of_Multiple_Deprivation_December_2015_Lookup_in_England.csv 
- you will need to to set the Geometry Definition  No geometry

Go to Data Source Manager > GeoPackage > New

Select LLSOA_Dec_2011_England_Wales.gpkg

Click , then select the table and Connect Add

Open the attribute tables for both Index_of_Multiple_Deprivation_December_2015_Lookup_in_E
 and  - notice that  in the former has angland LLSOA_Dec_2011_England_Wales  LSOA11CD

one-to-one relationship to  in the latterlsoa11cd
Follow the course notes to create a join between these two layers

Check the attributes of  to ensure the data has been joinedLLSOA_Dec_2011_England_Wales
correctly
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10.3. Styling Maps

10.3.1. Objective

Add styling to the data you have been working with, replacing the QGIS default styling, and add some
annotations and labels.

Use the project you created in the last exercise, or if you don't have it, open anessentials_03_styling.qgs 
d save it with a new name.

10.3.2. Styling the Map

Create a  style for the  layer- use and amend one of the QGIS styles, orSingle symbol canal_crt
create your own from scratch

Create a   style for the   layer, using a  or  markerSingle symbol wind_turbines_point SVG Font

Create a  for , with a suitable fill - use transparency or hatching toCategorized style aonb_wales
make the layers underneath visible

Create symbols and name labels for the  layerrailway_naptan

Create a  for the  layer, using the  fieldGraduated style LLSOA_Dec2011_England_wales IMD15

10.3.3. Add Annotations

Add two or three text annotations to your map, indicating some points of interest from the OS OpenData
layer, with appropriate text. Edit the formatting, and choose a different symbol for each annotation.

10.3.4. Loading a Style

This section covers the use of a ready-made style - for this you are going to use OS MasterMap, and load a
saved style from a qml file.

Load the osmm_topo_area shapefile

Zoom to extents, noting the sample covers the city of Exeter

Load the style for MasterMap osmmstyle.qml

Have a look at the style, and how it is constructed

10.3.5. Additional Tasks

Apply a  style to , using the  field for exampleCategorized wind_turbines_point STATUS

Look at some of the fill styles for polygons under  layer type - for example , Symbol Centroid fill Sha
peburst fill
For a line or point, create a symbol with multiple components
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10.4. Selecting and Querying

In this exercise, you will work on selecting features, and writing and running queries to filter layers.

You can work with the same project as you were using for the previous exercise, or load a fresh version of
it from  and save it under a new name in your  folder.essentials_03_styling.qgs Documents

10.4.1. Identify Features

Use the ool to look at attribute values on some of your layers Identify Features t

Have a look at the  section, and use the  option to see a Derived Auto open form forms dialog

10.4.2. Manual Selection

Use the selection tools to create some manual selections on the map, and compare the results in the
attribute table for the layer

Make manual selections in the attribute table, and use the  and  tools to viewZoom map Pan map
them in the map

10.4.3. Selection using an Expression

In the attribute table for , select the 100 LLSOAs with theLLSOA_Dec_2011_England_Wales
highest Index of Multiple Deprivation - note that the   field is a ranking, so the lowest numberIMD15
represents the highest IMD 

Save the selection as a new GeoPackage file in your  folderDocuments
Using the new layer of top 100 LLSOAs, select those where the area is less than 100,000 hectares

Select all the LLSOAs in Tower Hamlets, using  (for a case-insensitive search) and the  wildcILIKE %
ard character 

10.4.4. Field Calculator

Create a new field which contains the name without the code at the end - i.e. omitting the last five
characters

You may want to do this in two steps - either by creating two columns, or by nesting the operators:
Using the  operator  to get the length of each nameString length 

Create a is five characters less than thenew field of datatype , with a length which string
original, using the  operatorleft

10.4.5. Spatial Queries

In , use  on the  toolbar toLLSOA_Dec_2011_England_Wales Select Features by Value Attributes
select LLSOAs in Tower Hamlets (you can use Starts with from the   dropdown on theExclude field

)right

Use  in the  to find all railway stations which fall within theseSelect by location Processing Toolbox
LLSOAs

Forms
Note that this dialog will only appear if you have selected a single feature - you may need to
zoom in to do this.
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Use  to add the attributes of the containing LLSOA features to each ofJoin attributes by location
the the railway stations you have found in Tower Hamlets

10.4.6. Filter Layers

Use one of the queries you have already created - or create a new one - and apply to one of the
layers on the map

Apply the same query as an attribute table filter
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10.5. Loading Raster Data

This exercise shows you how to add raster background mapping layers, and to add a set of raster images
from a folder.

10.5.1. Load individual rasters

Create a new project file and save it in your  folderDocuments

Click , then Open Data Source Manager Raster

Browse to and  in  (use Ctrl-click to select multiple files)open the .tiff files Data/raster/1250K

, and put these images in itCreate a group

10.5.2. Create a Virtual Raster

Go to Raster > Miscellaneous > Build Virtual Raster

Select the files you want to include in the raster - use the files in Data/raster/VMD

Uncheck , Place each input file into a separate band and set a location for the output file

Click Run in Background to create the virtual raster and load it into the map - this will take several
minutes to complete

Set scale dependencies on the raster layers you now have loaded, so they appear at appropriate
scales

10.5.3. Load WMS layers

Go to   (or another site with WMS data sources if you prefer)http://data.gov.uk

Search the site for a WMS layer, and copy the link

Use the  to create the connection, and load layers from the site Data Source Manager

Virtual Raster
Note that this exercise takes several minutes to run in the AppStream environment - you will need to
wait for the processing to complete.

http://data.gov.uk
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10.6. Data Creation and Editing

This exercise covers creating and editing vector data, both in the map and in the attribute table.

10.6.1. Create features

Create a new GeoPackage layer in your  folder. Ensure that it is a polygon type, and hasDocuments
the following attributes:

name (text)

date (date)

reference (integer).

Specify the CRS as EPSG:27700
Create two or three new features in the layer, populating the attributes when prompted

When this is done, open the attribute table for the layer, and make further edits

10.6.2. Edit features

Open one of the layers you have been using, and amend the geometry of some of the existing
features, including lines, points and polygons

Use  to create new featuresCopy/Paste
Use the tools in the  toolbar to amend the geometry, includingAdvanced Digitizing

Split Features: craw a line across a feature to split it into two

Extend Features: draw an extension to a feature

Rotate Features: turn features round

Add part: add a new part to a multipart features

10.6.3. Snapping and tracing

Turn on the , and activate snappingSnapping Toolbar

Use the second button to go to , and set snapping to one of the layers - forSnapping Options
example  - with a tolerance of 50 metresrailways_naptan
Create a new line layer, and draw lines between railway stations to create a representational map of
part of the railway network, with vertices snapping to existing stations

Turn on  in the toolbar, and create a new AONB, which adjoins one of the existingEnable Tracing
AONBs, using tracing to make part of the boundary coincide

Tun on  in the toolbar, and adjust one of the common boundaries in aEnable Topological Editing
polygon layer, for example in LLSOA_Dec_2011_England_Wales
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10.7. GeoProcessing for Analysis

This exercise uses  to address some spatially-relateda combination of geo processing techniques
questions.

10.7.1. Buffer and select points in polygon

Create a new project and save it

Open the  and  layersnat_parks_england railway_naptan
Create a 10km buffer round the Lake District National park

Use  to find out how many railway stations are within 10km of the parkSelect by location

10.7.2.  Create centroids and a distance matrix

Open the  layer county_region_england

Use the  process to create a layer of the centroid of each countyCentroids

Use a  to find the three nearest railway stations to each centroid Distance Matrix

10.7.3. Create a hexagon grid and a point count

This stage visualises the density of railway stations across Great Britain.

Using the   tool, create a hexagon grid to cover the extent of the railway stations layerCreate grid
Zoom to the extents of the railway stations layer

Create a 30km hex grid for the extents of the layer, with settings something like:
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Use  with the grid as the polygon layer, and the railway stations as the Count points in polygon poin
ts layer

Create a style to visualise the results, using the field name specified in  in theCount field name
previous step (e.g. NUMPOINTS)
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10.8. Print Layouts

Use a project file from an exercise of your choice to create a Print Composer page. Use as many of the
tools and features as possible, as covered in the course notes, including:

: including editing the legend in the Print ComposerLegend

: including adjusting settingsScalebar

: of your choiceImage

: try using some HTML, and/or an expressionText

: change the settings to include a subset of the attributesTable

: with an extent indicator on the main map, formatted as a red outlineOverview map

When you have loaded all the elements onto the page, if you have time, fine-tune the layout to improve the
quality and usability for the reader.

When you have finished, save the result as a PDF and also as a PNG image into a suitable location, with
your name as part of the filename - we will review some of the final maps together.
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